Welcome to the Forum Archive!

Years of conversation fill a ton of digital pages, and we've kept all of it accessible to browse or copy over. Whether you're looking for reveal articles for older champions, or the first time that Rammus rolled into an "OK" thread, or anything in between, you can find it here. When you're finished, check out the boards to join in the latest League of Legends discussions.


Hit play and the launcher disappears but nothing comes up

Comment below rating threshold, click here to show it.




It took me forever to get this patch downloaded, a good 4 hours of reinstalling/re-opening etc... finally got the Play button to turn orange, clicked it, and nothing happened. Restarted my computer and again, nothing happened when I click play. I've tried hitting "run as administrator" and that didn't work either..

Riot please fix this, seems like there are endless posts about launcher problems when patches come.


Comment below rating threshold, click here to show it.


Senior Member


Its possible your firewall may be interfering with game execution. I would recommend reading: http://support.leagueoflegends.com/entries/20132793-firewall-configuration-for-league-of-legends so that you can eliminate that as the source of the issue.

Comment below rating threshold, click here to show it.

Wrenchman Golin

Senior Wrenchmen


This issue can occur when your computer is unable to connect to the server which causes the login screen to not appear.

Try the following:

  • Close League of Legends.

  • Allow all League of Legends processes through your firewall:
    • Adobe AIR Debug Launcher
    • LOL.Launcher
    • League of Legends Client
    • Pando Media Booster
    • PVP.net Patcher
    • PVP.net Patcher Kernel

  • Port forward the following:
    • 5000 - 5500 UDP - League of Legends Game Client
    • 8393 - 8400 TCP - Patcher and Maestro
    • 2099 TCP - PVP.Net
    • 5223 TCP - PVP.Net
    • 5222 TCP - PVP.Net
    • 80 TCP - HTTP Connections
    • 443 TCP - HTTPS Connections

      You can check if your ports were forwarded correctly through: http://www.firebind.com/lol.php

  • Update Windows fully--important and optional updates:
    • http://windowsupdate.microsoft.com/
    • Restart the computer

  • Reset your Internet Options and Automatically Configure your Settings:
    • Open Internet Explorer 9
    • Go to Tools > Internet Options
    • Go to the Advanced tab > Reset... > Check Delete Personal Settings > Reset
    • Go to the Connections tab > LAN Setting > Check only Automatically Configure Settings > OK
    • Click OK.

Comment below rating threshold, click here to show it.




Riot i have same problem ! please help me fast ! : http://imageshack.us/photo/my-images/221/loginblind.jpg/ !!!