Welcome to the Forum Archive!

Years of conversation fill a ton of digital pages, and we've kept all of it accessible to browse or copy over. Whether you're looking for reveal articles for older champions, or the first time that Rammus rolled into an "OK" thread, or anything in between, you can find it here. When you're finished, check out the boards to join in the latest League of Legends discussions.

GO TO BOARDS


Shaco's Deceive problems

1
Comment below rating threshold, click here to show it.

Reaver Forte

Senior Member

04-01-2010

i dunno about anyone else but i'm having some real ****ed up problems with shaco's decieve. sometimes i deceive and i don't cloak, just blink. sometimes i deceive in the midst of battle and still die, even if i blink out of the battle itself. sometimes i deceive and just as it ends, i attack, and it doesnt crit (the animation isnt even a crit).

does anyone else have problems with this?


Comment below rating threshold, click here to show it.

rayqua

Senior Member

04-01-2010

yup i am, and its really irritating.


Comment below rating threshold, click here to show it.

ThunKek

Member

04-01-2010

welcome to the world of the interwebs were theres lag


Comment below rating threshold, click here to show it.

Reaver Forte

Senior Member

04-01-2010

Quote:
ThunKek:
welcome to the world of the interwebs were theres lag

so, deceiving and then not getting cloaked can be blamed on lag?

...
...

yes, i know it CAN, but it shouldnt be. i can understand if blinking but still dying can be blamed on lag, or MAYBE no criting out of a blink, but it's more annoying when you dont cloak AT ALL.


Comment below rating threshold, click here to show it.

Kaidence

Senior Member

04-01-2010

Yeah it is not lag it is some bug with being hit near or the same time you hit deceive. It is a really annoying bug and has been going on ever since I started playing Shaco over a month ago. Happens to me at least 3 times a game.


Comment below rating threshold, click here to show it.

Calexisana

Senior Member

04-01-2010

Happens, also sometimes if you're spam clicking the enemy it won't actually hit them at all and will simply destealth you. Lag ftw


Comment below rating threshold, click here to show it.

malphismia

Senior Member

04-01-2010

It was just a recent bug, they better fix it. I havent had this problem until lately, and i main shaco.


Comment below rating threshold, click here to show it.

Naphtal

Recruiter

04-01-2010

its not lag. i've tried and tested this. what happens is that you see the "poof" of the smoke under your shaco but you don't teleport don't become invisible. or you teleport but dont go invis w/o any crit dmg. yet your ability goes into CD. for some reason this occurs when your doing an auto attack


Comment below rating threshold, click here to show it.

Azing

Senior Member

04-01-2010

Wrong section. its a bug thats been happening. I say its a stealth nerf by roit since Shaco is so OP on TT.


Comment below rating threshold, click here to show it.

malphismia

Senior Member

04-03-2010

Can this be moved to the bug section? Its a bug that needs to be fixed QUICK.


1