Server Status Unavailable then undefined

Comment below rating threshold, click here to show it.

Dymlos

This user has referred a friend to League of Legends, click for more information

Junior Member

07-10-2011

So, I can't play LoL anymore.

I have painstakingly gone through everything listed with The Wrenchmen toolbox guides, etc. I've tried system restoring to an earlier date, I've tried uninstalling/reinstalling (properly). Tried turning my firewall off, using a registry cleaner, yo name it.

They symptom is that when I run the Launcher, first it says Unavailable for server status (and no news populates), then after many seconds it switches to Undefined. Whenever I close the launcher, I also have to manually kill it in the task manager.

I've tried un/reinstalling Adobe AIR, Pando, running Windows updates, adjusting my clock, literally, every fix on all the lists I could find. When I was done, I tried a system restore to before the problem. No dice.

-------

I have a theory: For whatever reason, some files are missing, such as lol.game.version or perhaps others. I was unable to attempt certain fixes because the FTP of the game is down.

Any recommendations? I've searched through the knowledge base and submitted a ticket, but this problem has gone on for about a day now, and no amount of restarting (including cable modem/router), or other troubleshooting is working.

Thank you.


Comment below rating threshold, click here to show it.

Dymlos

This user has referred a friend to League of Legends, click for more information

Junior Member

07-11-2011

Even just finished trying uninstalling again, from scratch, downloading the client again (to a new directory on a new drive) and installing to a new directory on a new drive...

What the hell game problem can linger through a system restore and a totally new installation?


Comment below rating threshold, click here to show it.

Dymlos

This user has referred a friend to League of Legends, click for more information

Junior Member

07-11-2011

I figured out the answer to my problem. Very oddly, my router was the cause of the problem, even though I had been playing LoL for months, and made no change to the router. I went through all the port-forwarding to no avail, so, the router is broken. What hindered me from finding this out earlier, is that the router worked perfectly otherwise! What an odd issue to run in to. Anyways, hope this helps you in the future if you encounter the same issues. For reference I was using a very old Linksys WRT54GC wireless G router (hard-wired), with the latest firmware. I bought it back in ~2005/6, so, it lasted 5-6 years without issue.


Comment below rating threshold, click here to show it.

Faitt

Junior Member

07-14-2011

i just somehow fixed it, ive reinstalled the game twice, did troubleshooting, did a system recovery which is what i think fixed it, and did the repair option in the start menu in the cog options. Hopefully this helps out