Still cannot Load Direct3d

Comment below rating threshold, click here to show it.

The Lil Vaughn

Member

05-19-2011

Is there anything else I can do to make it so it will load? I've downloaded the drivers, but it still will not let me, I don't know if it is because I have too many drivers installed or what, but it is still not working.


Comment below rating threshold, click here to show it.

sullensoliloquy

Junior Member

07-08-2011

im getting the cannot load direct3d error and ive tried DL'ing directx 9.0 (because that seems to be the popular fix to this problem) but thats a waste of time because it wont install if you have a later version installed so where do i go from here?


Comment below rating threshold, click here to show it.

LiLSummoner3113

Senior Member

07-08-2011

im having this problem after downloading the latest pacth


Comment below rating threshold, click here to show it.

Aregionius

Senior Wrenchman

07-08-2011

Looking at your DxDiag you have the incorrect video drivers installed for your video card.


Comment below rating threshold, click here to show it.

sullensoliloquy

Junior Member

07-08-2011

DxDiag said there were no problems and drivers are up to date. i have directx11 installed.


Comment below rating threshold, click here to show it.

SoloDragoon

This user has referred a friend to League of Legends, click for more information

Senior Member

07-08-2011

Quote:
Originally Posted by sullensoliloquy View Post
DxDiag said there were no problems and drivers are up to date. i have directx11 installed.
Are you sure you have the correct drivers? Check windows update, it 'should' keep you up to date with whatever version they have of your drivers.

Or if ATI card just hit there site get latest, same goes for nvidia.


Comment below rating threshold, click here to show it.

sullensoliloquy

Junior Member

07-09-2011

im sure about the drivers. ive tried updating through windows and the toshiba website, both say my drivers are current. windows is fully updated and i saw someone else say try running as admin, that didn't work.