"Disconnected from PVP.net" -> "Session Closed"

1234511 ... 22
Comment below rating threshold, click here to show it.

Antanaclase

Member

05-17-2011

Hello everyone.
I've had this problem for a few months, and it's getting really annoying.

I'll try to be as clear as possible.

Occurence of the problem:

- When I log in, if i don't do something active in the laucher every 20 seconds or so, I get disconnected from PVP.net. By "something active", I mean either open the shop or visit someone's or my profile. It sometimes doesn't even work and I still get DCed, I haven't been able to find out why.
- When I manage to get in a game (by refreshing the connection, as mentionned above), I have to refresh it too, by saving my masteries every 5 seconds, or the game doesn't even start for me, and I have to exit the launcher and restart LoL to reconnect to the game. Refreshing my masteries sometimes doesn't work, I don't know why either. And I'm usually unable to see what's being written in the chat before the game starts.
- When I finally manage to be in the actual game, when it's finished I'm on the "waiting for stats" screen. I can wait for 20 minutes, still won't change. When I press "skip waiting", it tells me I'm disconnected from PVP.net.

Those are the 3 cases where my problem happens.

Result of this problem:

It pretty simple. When I reconnect, the 1st action I do requiring a connection to the servers gets me a "session closed". Which leads to the launcher shutting itself down. It wouldn't be that much of a problem if there wasn't queue 75% of the time. Seriously, after 1 game in LoL, I'm already pissed off and stop playing...

What I've tried:

- I've reinstalled the game multiple times. In different languages. (I now play on EU) I've also installed the NA launcher, same problem.
- I've installed from different downloads (in case files were corrupted).
- I've run CCleaner between the installations.
- I've opened all the required ports
- I've disabled my firewall & windows firewall & my antivirus
- I've added lol.launcher.exe to the exceptions of Avira aswell.
- I've launched the game as an administrator.
- I've reinstalled AIR
- I've done upload/download speed tests, it's about 3.5Mo dl and 300Ko upload. (octets, not bytes)
- I can be on skype during all this without having the slightest latency/delay/interruption of the call.
- I've disabled peer-to-peer in the launcher.
- I've updated IE.
- I've sent a support ticket, no answer so far

Weird things:
- Sometimes, this bug doesn't happen. I don't know why, I haven't discovered anything different from usual at those times.
- This happenned to me before too, I was on Vista 32bit, and installed Seven 64 bit. Same problem.
- Before the game forced me to upgrade to the new launcher, I've had a time when this bug wouldn't occur, without any change from me.

My Computer:
- I'm running windows seven 64 bits, all my drivers are up to date.
- I'm wired to my modem, no WiFi, router is D-Link Dir-300.
- Ask if you need the hardware.

Sample of threads mentionning my problem:
- http://www.leagueoflegends.com/board...d.php?t=354348
- http://www.leagueoflegends.com/board...d.php?t=621490
- http://www.leagueoflegends.com/board...07#post8860907
- http://www.leagueoflegends.com/board...d.php?t=736840
- Find more by typing "site:leagueoflegends.com session closed" on google.

But usually, Wrenchmen answer once, and when it doesn't work, there's no more answer from RIOT tagged people.

I hope I've been clear enough, i'f theres any question, don't hesitate.

Thanks a lot to those trying to answer.

EDIT: Problem solved. I bought a new router, it seems my D-Link Dir-300 was at fault.


Comment below rating threshold, click here to show it.

Madman Reborn

Senior Member

05-17-2011

that's actually a very weird problem. Best thing to do is try finding the problem and then work for a solution instead of randomly trying solution. Let's a logical approach.

Now, the first you do is send in a support ticket. Since you allready tried everything else, no shame in doing that.

Now after you've done let's try and look at the fact. You get disconnect from chat true a session time-out. That means inactivity, but not neccecarely. Now From what I read on maestro the issue might be with is. What I think happens is the following. Maestro and pvp.net constantly send out signs to each others. When they miss these sign pvp.net shuts down.


Comment below rating threshold, click here to show it.

Antanaclase

Member

05-17-2011

Oh yeah I forgot to mention it, but I sent a support ticket a few days ago. No answer so far.

I have no idea what maestro is actually, so I can't tell if it's a good idea or not. ^^


Comment below rating threshold, click here to show it.

Antanaclase

Member

05-18-2011

Bump


Comment below rating threshold, click here to show it.

Lagenor

This user has referred a friend to League of Legends, click for more information

Senior Member

05-18-2011

I have this issue a lot too, so do all of my friends, I think it's with the client itself, not from our sides.


Comment below rating threshold, click here to show it.

Antanaclase

Member

05-18-2011

Yeah, I think too... But there HAS to be something different on our computers that makes this error occur.
So far i have tried everything mentionned in the threads on this forum (and EU one too), without result.


Comment below rating threshold, click here to show it.

Madman Reborn

Senior Member

05-18-2011

http://support.leagueoflegends.com/e...al-information

the link about maestro. Basicly, maestro is the thing that actually launches the game(since pvp.net can't do it).

This part in particalur leads me to believe the problem has something to do with this, mainly because you say you have to be "active" every 20 seconds or so.

"Since PVP.net and the game client cannot communicate directly, Maestro must monitor the health of both applications. It does so by sending and receiving heartbeats. PVP.net sends heartbeats to Maestro every 5 seconds. Maestro sends a heartbeat to PVP.net every 15 seconds. If PVP.net misses two heartbeats in a row (30 seconds), then it terminates itself. If Maestro misses too many consecutive PVP.net heartbeats, Maestro kills PVP.net"

What it seems to me is that the thing in PVP.net that recieves the heartbeat doesn't work or stops working to soon. It has to be this way because if maestro would should down you wouldn't have the error saying that connection got terminated because of inactivity. What strikes me as odd is that it isn't fixed by reinstalling.


Comment below rating threshold, click here to show it.

Antanaclase

Member

05-18-2011

Well this has led me to double checking my ports in my routeur's firmware, and apparently, 8393-8400 (maestro/pvp.net ones) were the only ports that didn't register as open.
I've opened it and so far no DC after 20 minutes with the launcher open.
Fingers crossed, I'll check if it goes on for the next few days

Thanks a lot anyway Madman!


Comment below rating threshold, click here to show it.

Madman Reborn

Senior Member

05-18-2011

Happy to help, really hope this fixes the problem for you.


Comment below rating threshold, click here to show it.

Wrenchman Golin

This user has referred a friend to League of Legends, click for more information

Senior Wrenchmen

05-18-2011

Try testing your ports via http://www.firebind.com/lol


1234511 ... 22