Users experiencing problems with new patcher

First Riot Post
Comment below rating threshold, click here to show it.

mpasma

Junior Member

08-20-2012

well ive downloaded the patch , clicked on the play botun but it couldnt load the login screen ...with theses moves is it posible to get fixed ?


Comment below rating threshold, click here to show it.

Cookieswithtacos

Junior Member

09-10-2012

Quote:
Originally Posted by RivingtonThe3rd View Post
Our teams are looking into the issues that several people are experiencing with the new patcher.

Some things that have been working for people:
- Run as administrator
- Give the patcher some time to run
- Do not click during League of Legends logo
- Be sure to install to C:\Riot Games

We will continue keep the community updated. If you have not checked out the sticky from, Eambo please see the following http://www.leagueoflegends.com/board...d.php?t=714338

Please post your issues here so our engineers can review what problems you are experiencing.

----- Edit -----
Please know that everything will be fixed when the patcher is hot fixed/updated. Please try the following as a temporary work around:

Update:Please provide the logs in your RADS folder so we can view the different errors that people are receiving. This will greatly help us to resolve the issue throughout different environments. These logs will be forwarded directly to our RADS team for further review.

5/4 11:30AM -
Update: I would like to thank everyone again for providing their logs and information about the patcher. This is the most recent update I have received from our RADS team.

1. Download http://l3cdn.riotgames.com/releases/...ser_kernel.exe
2. Replace <install directory>/RADS/system/rads_user_kernel.exe with this file.
3. Try launching it again
now it works and launches but now i cant connect to the pvp.net server any help on this one?


Comment below rating threshold, click here to show it.

barr3t

Member

09-28-2012

followed the steps and patcher loads, but after clicking the play button nothing loads up.... guess im retired from LOL now?


Comment below rating threshold, click here to show it.

Comrade Cooch

Junior Member

10-29-2012

Anybody still looking for a fix I recently upgraded to windows 8 and it gave me this problem, After trying everything and nothing working I changed compatibility to windows 7 and nothing. Tried again set it to windows xp and everything worked!


Comment below rating threshold, click here to show it.

Keepsake66

Senior Member

10-29-2012

yeah im getting huge issues. the login screen does not load after clicking play on the patcher window. i have yet to try absolutely everything said in the opening message but i will attempt and see what happens. does anyone know if this problem is at all related to me having a mac that runs windows?


Comment below rating threshold, click here to show it.

redfoxx

Junior Member

12-02-2012

I was having this issue;
I uninstalled like 7 times (no exaggeration), tried just about everything that was posted on the forums, then I came across one post that the guy suggested installing both .net framework 4.0 and .net framework 3.5.
I just got home from being gone all day; my computer left to download 3.5
I just tried running the LoL patcher, and this is the first time that I didn't get the rads error.
It is patching right now as we speak.
--I'll keep everyone posted on how it turns out.


Comment below rating threshold, click here to show it.

gg Top

Senior Member

12-09-2012

Love you thanks! <3


Comment below rating threshold, click here to show it.

Zandrethell

Junior Member

12-14-2012

Hello, thought I would post my process for (finally!) fixing this. If you want to copy my process, make sure you have the exact same OS:
I am running XP pro (32bit) SP3 on a custom box.

Originally, I downloaded normally to F: drive (which is my boot drive btw), got the error immediately upon opening. Tried un/reinstall to no effect. Then tried installing C++ which I don't think I had before (point of interest, if you need this, make sure you download the 2010 or latest version for your OS and get the x86 version if your OS is 32 bit, this can be confusing as there is a separate 64bit version) and dot net framework v4. No dice.

Finally, I decided to uninstall everything, including dot net and C++ (which it turns out I had multiple versions of in my program list), neither of which had I uninstalled previously. I reinstalled starting with dot net--this time v3.5 as v4 is in beta currently (though I've read that LOL is supposed to work with either). Next I reinstalled the 2010 C++ x86 redistributable package. Finally, (and as it turns out, using the same setup files I originally downloaded) reinstalled LOL. Also at this time I tried that DNS trick (using 8.8.8.8 and 8.8.4.4 as my default and additional DNS servers) with a quick DNS flush and restart. When I logged back into windows, LOL started up like a charm. No further issues.


Comment below rating threshold, click here to show it.

Augasm

This user has referred a friend to League of Legends, click for more information

Junior Member

12-16-2012

Quote:
Originally Posted by Leib Olmai View Post
One thing that might help is to get CCleaner and run Registery clean after patch.
After the migration, I've found 3149 registery errors with it. With the last hotfix I've found 2. Every patch there's error related to LoL. For the people who had Custom skin, it might also help to run those.

I've been doing that since I play LoL, running CCleaner after each patch (patch finish, close client, run CCleaner) then reopen the patch. I never, ever had one patcher problem.

Alot of DLL error can be find, and I guess it's because riot change their path of folder or whatever they change often.

But I'm pretty sure CCleaner help, alot.
Sorry.....

alot


Comment below rating threshold, click here to show it.

CRayeMagic

Junior Member

12-27-2012

hey im still having this problem failed to launch RADS\system\rads_user_kernel.exe i seriously have tried everything i need SOME HELP PLZZ !?