Welcome to the Forum Archive!

Years of conversation fill a ton of digital pages, and we've kept all of it accessible to browse or copy over. Whether you're looking for reveal articles for older champions, or the first time that Rammus rolled into an "OK" thread, or anything in between, you can find it here. When you're finished, check out the boards to join in the latest League of Legends discussions.

GO TO BOARDS


Recent Massive FPS Lag Spikes - Windows XP solution

1
Comment below rating threshold, click here to show it.

Unmiracle

Member

01-23-2011

Well, it worked for me. It's kinda of a hard work, and it's not guaranteed to work with everybody, but it solved my problem (well, the last game I played with Malzahar - which previously caused my game to FPS lag each 1min30secs - didn't have any fps drop at all).

First of all, download a program called Little Registry Cleaner. It's a very useful software that cleans your registry.

Then, download CachemanXP. Inside the program, set LolClient.exe STICKY priority to lowest, and League of Legends.exe to STICKY priority to Real Time. Sticky priority will make these processes always start with this priority.

Then open up msconfig and add this line at the System.ini tab, under the 386enh configuration

ConservativeSwapfileUsage=1

This will make WinXP use the Swapfile only when needed.

then open up regedit and go for the key: HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Session Manager\Memory Management

Set the following values

DisablePagingExecutive to 1
LargeSystemCache to 1

those will allow the system's kernel free up some ram for you.

Now add a dword value called IOPageLockLimit and if you have more than 512mb (which probably is the case), set it to 40000

Now hit WINDOWS+BREAK to open up the System Properties Window. Go into the Advanced Tab, then click Settings for the Performance (it's the first Settings Button on this tab).

Under Visual Effects, set the option to Adjust to better performance. In this same window, go for the Advanced Tab and check your Virtual memory Settings. The size for the Swap File should be in the recommended setting shown at the bottom of that window.

Apply all your changes, and reboot your machine.

Start a LoL game and set your FPS cap to 30.

When I did ALL of this stuff, it stopped FPS lagging for me. Hope some of you can have the same luck as me.


Comment below rating threshold, click here to show it.

1nv1nc1b1l1ty

Junior Member

01-23-2011

No, I'd rather they fixed the actual game. None of this is the problem. I can benchmark 3DMark Vantage on full with consistent FPS higher than I get on LoL with everything turned down. LoL consumes too much RAM after last patch and it forces a bottleneck in the system.


Comment below rating threshold, click here to show it.

ebben

Senior Member

01-23-2011

Unmiracle, it'll be a miracle if I get all that right but I may give it a shot. I'm using cacheman already to give priority to leagueoflegends.exe ... why are you giving lolclient lowest priority?

Thanks for your efforts!


Comment below rating threshold, click here to show it.

Birdman Hand Rub

Senior Member

01-23-2011

Quote:
Unmiracle:
Well, it worked for me. It's kinda of a hard work, and it's not guaranteed to work with everybody, but it solved my problem (well, the last game I played with Malzahar - which previously caused my game to FPS lag each 1min30secs - didn't have any fps drop at all).

First of all, download a program called Little Registry Cleaner. It's a very useful software that cleans your registry.

Then, download CachemanXP. Inside the program, set LolClient.exe STICKY priority to lowest, and League of Legends.exe to STICKY priority to Real Time. Sticky priority will make these processes always start with this priority.

Then open up msconfig and add this line at the System.ini tab, under the 386enh configuration

ConservativeSwapfileUsage=1

This will make WinXP use the Swapfile only when needed.

then open up regedit and go for the key: HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Session Manager\Memory Management

Set the following values

DisablePagingExecutive to 1
LargeSystemCache to 1

those will allow the system's kernel free up some ram for you.

Now add a dword value called IOPageLockLimit and if you have more than 512mb (which probably is the case), set it to 40000

Now hit WINDOWS+BREAK to open up the System Properties Window. Go into the Advanced Tab, then click Settings for the Performance (it's the first Settings Button on this tab).

Under Visual Effects, set the option to Adjust to better performance. In this same window, go for the Advanced Tab and check your Virtual memory Settings. The size for the Swap File should be in the recommended setting shown at the bottom of that window.

Apply all your changes, and reboot your machine.

Start a LoL game and set your FPS cap to 30.

When I did ALL of this stuff, it stopped FPS lagging for me. Hope some of you can have the same luck as me.


For the time being this has worked for me.
Thank you for being more supportive than the company!


Comment below rating threshold, click here to show it.

Arcko

Junior Member

01-23-2011

Wonder if this would work for Windows 7.... must test later...


Comment below rating threshold, click here to show it.

Unmiracle

Member

01-23-2011

Quote:
ebben:
Unmiracle, it'll be a miracle if I get all that right but I may give it a shot. I'm using cacheman already to give priority to leagueoflegends.exe ... why are you giving lolclient lowest priority?

Thanks for your efforts!


I SEE WHAT YOU DID THERE lol

well, lolclient.exe is a background process, when the game is running, it's the League of Legends.exe the active process, and as LolClient.exe also leaks, I give it lowest priority so its requests for more RAM are seldom granted by the system.


Comment below rating threshold, click here to show it.

Birdman Hand Rub

Senior Member

01-23-2011

so the number at the bottom of my virt memory thing was 2046 does that mean my swap file line should say
ConservativeSwapfileUsage=2046

?


Comment below rating threshold, click here to show it.

Unmiracle

Member

01-24-2011

Quote:
ToriiX:
so the number at the bottom of my virt memory thing was 2046 does that mean my swap file line should say
ConservativeSwapfileUsage=2046

?


No.

ConservativeSwapfileUsage=1 means

"Windows, please use the Swapfile only when needed." That 1 is a value of "true", or, "yes, I want the ConservativeSwapfileUsage setting on".

At the bottom of the virtual memory thing was 2046. So, you click settings on the virt memory thing, and at the bottom of this new window, there will be something like this:

Actual: 2046
Recommended: 3037
Max: 4096

In this case, you would set the box on that window to 3037 and apply. If the recommended is 2046, you leave it unchanged, but that is on the window where the Virtual memory Settings is shown, you do not use the ConservativeSwapfileUsage for that

ConservativeSwapfileUsage value must be 1, defaults at zero.

Hope it helps.


Comment below rating threshold, click here to show it.

Birdman Hand Rub

Senior Member

01-25-2011

one last question ;P and thank you btw for answering the last one

i already had a dowrd value with the name listed in the original post should i add another one or no?

PS: the dword value i had was Io instead of IO


Comment below rating threshold, click here to show it.

Unmiracle

Member

01-26-2011

If it is already that value you do not need to add another one.


1