Welcome to the Forum Archive!

Years of conversation fill a ton of digital pages, and we've kept all of it accessible to browse or copy over. Whether you're looking for reveal articles for older champions, or the first time that Rammus rolled into an "OK" thread, or anything in between, you can find it here. When you're finished, check out the boards to join in the latest League of Legends discussions.

GO TO BOARDS


My List of Mac Issues

123
Comment below rating threshold, click here to show it.

wumbla

Member

03-31-2014

I also have the same problems stated in the OP.
Although, the long loading screen seems to be more recent. I used to have no problem loading very fast, but as of the last few months, I load extraordinarily slow compared to others in game.
I have noticed looking at my activity monitor that the long loading may have something to do with the userkernal going unresponsive for periods of time.


Comment below rating threshold, click here to show it.

Mike4Real

Senior Member

03-31-2014

I have a couple updates to the 4 problems we talked about, but I have no idea if they plan to get outta beta at any time.

3. Right Before Death, Screen Freezes:
This issue was improved a tiny bit in the 4.4 patch. I went from freezing 100% of the time on my first death to freezing about 80% of the time, which still sucks but they are working on it, and their communication about the issue has gotten a lot better. I notice that if I play a custom game with just 1 enemy bot, I probably won't freeze, but in a normal game I still usually freeze. The main thread for this issue now is here:
http://forums.na.leagueoflegends.com/board/showthread.php?t=4008524&page=9
4. After Game Lag/Bug Splat:
According to a post from Riot in this thread:
http://forums.na.leagueoflegends.com/board/showthread.php?p=46045112#46045112
This issue has also been happening to some people on the Windows client. And they also expect to have it fixed when patch 4.5 comes out.


Comment below rating threshold, click here to show it.

hobbesocrates

Junior Member

04-15-2014

I'm having all of the same issues:

1. Extremely slow load (always last)
2. Extremely low fps for first few seconds of the game (<5 for ~20 seconds)
3. Occasional lag during/after first death (.5 seconds, both my death and other's)
4. Infrequent lag after death (just mine, every death, still .5 seconds)
5. Big lag spike during end game shopping (eg buying pots, ~1-2 sec.)
6. Occasional bug splat at end of games (around 30% of time)

Usually, my game can run at a stable 120fps on medium settings, and changing settings to low do not appear to solve any of the issues. I recently repaired the client and repaired permissions, and problems still persist.

My specs:

OS 10.9.2
2.3 GHz Intel i7
8GB DDR3 1333 MHz
AMD Radeon HD 6750M
Automatic Graphics Switching: Off


Comment below rating threshold, click here to show it.

Mike4Real

Senior Member

04-16-2014

Quote:
hobbesocrates:

4. Infrequent lag after death (just mine, every death, still .5 seconds)


Yeah, I now have freezes when other people die near me, its most noticeable on ARAM, but like you said its not 100% consistent. Also similar things happens when I place a ward in a bush for the first time. The scary part for me is that your computer specs are sooooo much better than mine. All of these problems are still happening on new Macs, so even my thoughts about getting a new computer would not help me. I just don't know if they can ever fix these problems when people on new Macs are starting to have them. I just might go to the dark side and use bootcamp at this rate.


Comment below rating threshold, click here to show it.

xMonster Craverz

Junior Member

06-28-2014

I'm using an iMac late 2012 and i don't get these issues that you are experiencing.


Comment below rating threshold, click here to show it.

Cookies x2

Junior Member

08-03-2014

Hi guys,
I was playing LOL yesterday (Mac Client) and after i queued up for a match the game crashed just before the 5v5 splash art screen,
So then I tried reconnecting back in and then it just went Black, couldn't tab out, it wouldn't load anymore.
I tried shutting my Mac down then re-loging back into the game, champion select went fine then when the game was supposed to start the same thing happened no splash art 5v5 screen just total blackness from the abyss.
I even tried uninstalling it reinstalling it but guess what?! the same problem... is there a way to fix this or am i doomed ?


Comment below rating threshold, click here to show it.

iiSkaterDomo

Junior Member

08-06-2014

Quote:
Cookies x2:
Hi guys,
I was playing LOL yesterday (Mac Client) and after i queued up for a match the game crashed just before the 5v5 splash art screen,
So then I tried reconnecting back in and then it just went Black, couldn't tab out, it wouldn't load anymore.
I tried shutting my Mac down then re-loging back into the game, champion select went fine then when the game was supposed to start the same thing happened no splash art 5v5 screen just total blackness from the abyss.
I even tried uninstalling it reinstalling it but guess what?! the same problem... is there a way to fix this or am i doomed ?


Same thing happening to me, Riot support said it had something to do with my router, but It can't be , because I am not the only one with this problem. You may be doomed. let me know if you get it fixed.


Comment below rating threshold, click here to show it.

Lahu4Life

Junior Member

08-08-2014

Quote:
Cookies x2:
Hi guys,
I was playing LOL yesterday (Mac Client) and after i queued up for a match the game crashed just before the 5v5 splash art screen,
So then I tried reconnecting back in and then it just went Black, couldn't tab out, it wouldn't load anymore.
I tried shutting my Mac down then re-loging back into the game, champion select went fine then when the game was supposed to start the same thing happened no splash art 5v5 screen just total blackness from the abyss.
I even tried uninstalling it reinstalling it but guess what?! the same problem... is there a way to fix this or am i doomed ?


I feel your pain. I was in a 5v5 game then my screen froze. I log back in to reconnect, nothing but a black screen. After waiting about an hour, I log back in, team select went smooth but when the loading screen came up, nothing but a black screen. I tried multiple times and same thing still happened, I tried everything on league of legends support like uninstall, reinstall, forcing re-patch, changing display/resolution, turning off firewall, etc.. Still no results so I'm waiting for them to email me back with a solution.


Comment below rating threshold, click here to show it.

softstone

Junior Member

09-17-2014

Hey fellow LoL players I have a question that I hope you guys can answer. Fro about the last 3 days my league of legends loading screen freezes on the black, but not the actual champion splash art part. My launcher,patcher. and lobby work just find it's just when I get dine choosing champs and the loading begins.

Please help I'm desperate for some league. Your my only hope.


Comment below rating threshold, click here to show it.

Kills On You

Junior Member

09-21-2014

I see we are all having same issueÂ… did anyone find a solution to not loading after champ select. BTW tired my log in on a different computer and I was able to get passed champ select. No changes have been made to my mac or router. Issue started happen after i got a bug splat report.


123