Game Not Loading from Champ Select

Comment below rating threshold, click here to show it.

JohnnyV

Junior Member

01-08-2014

Hey all,

I've been having this issue with my game client recently. I'll attempt to load the game and the majority of the time it'll say another instance of the launcher is already running, to which I have to click "cancel" and try to load the launcher again. Finally after 5-6 times of this happening, I'll get the game screen. I'll login and queue up, no problems (typically) and then pick my champion. A lot of times i'll notice the game having an issue connecting to the server when I pick a champion. Anyways, the game will begin loading but I'll still be on the champion select screen (for a long period of time). So i'll have to act like I'm dodging the game and re-login. When I do, this typically prompts me to "reconnect to game" that I've supposedly left. I'll reconnect and the game will already be like 5 minutes in. Any fix to this issue?

I repaired my client yesterday and the client WAS working no problem. Today I played my first game and experienced the issue again.

Any help that you could provide on this topic would be much appreciated.

Thanks so much,

xAce of Hearts


Comment below rating threshold, click here to show it.

JohnnyV

Junior Member

01-08-2014

I'll try moving this over to another part of the forums as well.


Comment below rating threshold, click here to show it.

MBasaurus

Junior Member

01-11-2014

I'm having the same problem :P