15in Haswell rMBP poor performance?

Comment below rating threshold, click here to show it.

puremojo

Senior Member

01-06-2014

Specs listed below:

Processor: 2.3 GHz Core i7
Memory: 16GB 1600 MHz DDR3
Graphics: NVIDIA GeForce GT 750M 2048 MB (I turned off automatic graphics switching)

I get big lag jumps in game. Just randomly goes from consistent, nice, 60fps at high settings to like 20, just totally randomly.

No shadows, V-sync is on, but this shouldn't be causing this much trouble...Resolution in game is set to 1920x1080 (I'm playing on an external monitor via HDMI)

I know that it should be doing better than this because I get better FPS playing SC2 at high settings, which is WAY more graphics intensive...

Anyone else run into the same thing here?


Comment below rating threshold, click here to show it.

FreakinUnoriginl

Senior Member

01-07-2014

Have you tried playing with v-sync off, with FPS set to either High or Benchmark? I think that's in one of the recommendations that was discovered early on, but it doesn't seem to have been stickied.

Other than v-sync, your settings are the same as mine, and I have a 15" 2012 rMBP (2.3GHz Ivy Bridge, 8GB RAM, and GT 650m 1GB VRAM) and I'm running a 1920x1200 display with an average of 50FPS, dips as low as 40. (Very rare, brief, dips to 35.)

There will still be dips, but it should be much smoother than what you seem to be encountering.

The only other thing I can think of would be to do an SMC reset, but I think what you're describing is related to v-sync. If changing to one of the other FPS options doesn't work though, instructions for doing an SMC reset: < Apple support link >


Comment below rating threshold, click here to show it.

puremojo

Senior Member

01-08-2014

I just didn't think V-Sync would make such a huge difference.....well it did....

After I turned V-sync off, with settings on all High, I was getting like 150fps

I went to Very High settings and now get 80-110 fps, I don't think it's ever been below 60 since then.

FYI, both cases have shadows OFF


Comment below rating threshold, click here to show it.

puremojo

Senior Member

01-08-2014

Frame-rates are uncapped btw


Comment below rating threshold, click here to show it.

Xeculus

Member

01-08-2014

That's weird.

I have the same specced MacBook, and I'm running the 1680-resolution setting with maxed quality and I get about 100-120fps uncapped.
If I set the resolution to 2048, I get ~80fps.

My automatic graphics setting is on, however. Maybe that's the issue?


Comment below rating threshold, click here to show it.

puremojo

Senior Member

01-08-2014

Quote:
Originally Posted by StopDropNTr0ll View Post
That's weird.

I have the same specced MacBook, and I'm running the 1680-resolution setting with maxed quality and I get about 100-120fps uncapped.
If I set the resolution to 2048, I get ~80fps.

My automatic graphics setting is on, however. Maybe that's the issue?
Yes, DEFINITELY turn off the auto graphics switching