Welcome to the Forum Archive!

Years of conversation fill a ton of digital pages, and we've kept all of it accessible to browse or copy over. Whether you're looking for reveal articles for older champions, or the first time that Rammus rolled into an "OK" thread, or anything in between, you can find it here. When you're finished, check out the boards to join in the latest League of Legends discussions.


OS X Mavericks Bug

Comment below rating threshold, click here to show it.


Junior Member


Hi guys, I'm having a similar problem. Whenever I try to enter a match, my loading screen takes forever to build up to 100% then just disconnects before even entering the game. The client suggests I take a look at my Firewall, but thats not the issue since I allow incoming connections from League already. I did not have this problem whatsoever before upgrading to Mavericks. My system specs are:

15" MacBook Pro, early 2011
Processor: 2 GHz Intel Core i7
Memory: 4 GB 1333 MHz DDR3
Graphics: AMD Radeon HD 6490M 256 MB

Just restart ur laptop. It's a bug. Same thing happens to me sometimes, it happens to all of us (but its rare).

Comment below rating threshold, click here to show it.


Junior Member


Unfortunately after the update my league stopped working. does anyone have a solution for this? I would be eternally grateful.

Comment below rating threshold, click here to show it.


Junior Member


What I did to solve this problem (only in part unfortunately,) is to reset your pRAM and SMC. It didn't completely fix the issue, but after moving to Mavericks, resetting these did substantially help.


the other thing you can do is close out chrome and set priorities to league of Legends (and not for skype )

I use atmonitor for that. It's a free application.

Good luck guys, I hope it helps.