Sometimes get an "Unable to connect to server"/Firewall bug after Champion Select

First Riot Post
Comment below rating threshold, click here to show it.

Hope19

Senior Member

10-12-2013

Hi everyone! Recently I have been having an issue on the NA servers that seems to happen randomly and I was hoping to get some help with figuring out what is causing it.

The problem happens sometimes after champion select, where the client minimizes as usual, and the "League of Legends" logo pops up, but then instead of showing the loading screen with all the champions and summoner names, it's merely a black screen and then an error pops up like this. Regardless of what I try, when this error occurs there is nothing I can do except wait for the game to end, and then play again in which the next game will start normally. Just to reiterate this only happens SOME of the time, about once a day. Unfortunately, this leaves my team at a permanent disadvantage for the whole game, and gives me a "Leave" which really bothers me as I make it a goal to never leave or ragequit games. I'm beginning to worry about getting temporarily banned as well because of the leaves I've begun to wrack up due to this strange bug.

I come to you guys because I have basically tried everything that I could possibly think of. I'm actually a computer science major and I'm used to debugging programs so it really bothers me that I can't find out whats triggering this error or how to fix it. So far I have tried all of the following with nothing working definitively:

  • Sitting there pressing retry over and over as the message pops up again and again with no luck.
  • Turning off my firewall and antivirus
  • Restarting my computer (worked one time, but haven't been able to repeat successfully)
  • Closing and relogging into League
  • Manually closing all LoL processes in the task manager and then relogging into League
  • Removing "LogitechGkey.dll" and "LogitechLed.dll" from C:\Riot Games\League of Legends\RADS\solutions\lol_game_client_sln\release s\0.0.0.249\deploy as they files can supposedly cause a memory violation.
  • Note that I do live on a college campus, so I am unable to access the routers or modems used by the school, but as the game works fine the other 90% of the time, I don't see why it would be causing this.

I have searched Google extensively for hours and found tons of threads made by people with the same exact problem, but not one has a working solution. Please, if anyone has any insight into what could be causing this to happen so spontaneously and seemingly without cause, I would really appreciate your help. Thanks for your time.

-Hope19 of NA


Comment below rating threshold, click here to show it.

Phildo386

Junior Member

10-12-2013

I got nothing but i say we upvote it so something gets done cause i am tired of waiting for my two hour game to finish.


Comment below rating threshold, click here to show it.

XxRedMagexX

Recruiter

10-12-2013

http://forums.na.leagueoflegends.com...1#post42184262

Up vote this so it can be read by Mods/Admins and Developers.

I already up voted this fourm


Comment below rating threshold, click here to show it.

KFCFan

Member

10-12-2013

Bump. I am having this same problem and I submitted a ticket, please fix this.


Comment below rating threshold, click here to show it.

Hope19

Senior Member

10-13-2013

Bump for fix or more info.


Comment below rating threshold, click here to show it.

Hope19

Senior Member

10-13-2013

Bump.


Comment below rating threshold, click here to show it.

Hope19

Senior Member

10-13-2013

Bump.


Comment below rating threshold, click here to show it.

Luxious

Senior Member

10-13-2013

LoL Launcher Fix
Hopefully something can resolve your error in here.
Aside from this, have you tried deleting the entirety of your solutions folder rather then solely the specified files?
Further details could help resolve your issue


Comment below rating threshold, click here to show it.

Hope19

Senior Member

10-13-2013

Quote:
Originally Posted by Luxious View Post
LoL Launcher Fix
Hopefully something can resolve your error in here.
Aside from this, have you tried deleting the entirety of your solutions folder rather then solely the specified files?
Further details could help resolve your issue
Thanks for the response! No, I have not tried deleting the entire solutions folder yet, but would League auto replace that upon launching? Isn't it needed to run the game?

And as for the thread you linked, this is the only relevant thing I could find:

Quote:
Originally Posted by Luxious View Post
For those who are having the Bugsplat/Reconnect error
An equivalent means to resolve this problem is to
  • Bring up Task Manager (ctrl+alt+delete)
  • End Process for all League of Legends Applications
  • Right Click your LoL Launcher Icon
  • Go to Properties
  • Compatibility Tab
  • Check/UnCheck the Run this Program in compatibility mode:
  • Find Suitable Mode to Operate LoL (mine was Vista S1)
  • Run as Administrator
  • Apply Settings
  • (May have to restart computer, I have had to a couple times then other times I do not)
  • ReLaunch League
I never get a bugsplat with my problem, just an endless series of the same error message that I pictured in the original post. However, I will give it a shot the next time it happens anyways. Can't hurt to try! xD


Comment below rating threshold, click here to show it.

Luxious

Senior Member

10-14-2013

When you delete specified folders/files League will initiate a download which may seem like a small update
to replace the missing folders/files
There could have been several possible reasons as to what may have caused this and even as minor as
a corrupted file can cause it

eg I forgot I had plugged in my HDMI splitter yesterday to stream to my TV
In turn it gave me the "pvp.net patcher is not responding" today due to the resolution complication
So all I had to do was just unplug my splitter and it was corrected and fixed.