[RIOT PSA] FPS Issues? Check Settings first

First Riot Post
Comment below rating threshold, click here to show it.

Brentmeister

Associate Software Engineer

10-03-2013
1 of 1 Riot Posts

Greetings Mac players,

I've seen a few threads regarding FPS issues with the most recent patch. Unfortunately, it appears that a large number of players had their video settings reset this patch (Win and Mac users both).

if you're experiencing FPS issues be sure to check that your video settings haven't been reset.

Here's a short guide to the settings you want for optimal performance:

Shadows: Off
V-Sync: Off
Framerate Cap: Benchmark

Here is a player made guide that goes into some more depth:
http://forums.na.leagueoflegends.com....php?t=3751869

Cheers,


Comment below rating threshold, click here to show it.

Chief IronShaft

Senior Member

10-03-2013

The problem is that when I run the settings that I used to run before the patch, I get FPS drops (from a stable 60 to low 40's) in situations where any little thing is going on in game. The patch did reset my settings (from all Very High to all Medium)but that is really not the issue. I honestly refuse to believe that my computer should not be able to run League on max settings at a stable 60 FPS. You guys messed something up somewhere with this patch(maybe the new minion missile particles idk) and I hope it gets fixed soon.

PS: I have a PC but I am pretty sure this is a widespread issue on both Macs and PCs


Comment below rating threshold, click here to show it.

Chief IronShaft

Senior Member

10-03-2013

UPDATE:

I was messing around with the settings and I believe that it may be an issue with V-Sync.

Pre-Patch Settings:
1920 x 1080
Character Quality - Very High
Environment Quality - Very High
Effects Quality - Very High
Shadows - Very High
V-Sync ON
Frame rate cap - Stable(I believe that is what the option used to be called.

With these settings I would get a constant 60 FPS all the time. When I try running these settings after the newest patch, I get 60 FPS but once anything starts happening on the screen it can jump as low as 40 FPS. Obviously under "Frame rate cap" we no longer have as much options (only 60 FPS or Uncapped)so I tried it running it capped at 60 FPS.

Post-Patch Settings:
1920 x 1080
Character Quality - Very High
Environment Quality - Very High
Effects Quality - Very High
Shadows - Very High
V-Sync OFF
Frame rate cap - Uncapped

With these new settings I get anywhere from 150-300+ FPS depending on the visual strain so I guess I solved my problem....


Comment below rating threshold, click here to show it.

PathOfPein

Junior Member

10-03-2013

Do I put it to uncapped or 60fps?


Comment below rating threshold, click here to show it.

Chief IronShaft

Senior Member

10-03-2013

Quote:
Originally Posted by PathOfPein View Post
Do I put it to uncapped or 60fps?
Turn V-Sync OFF and put it to uncapped. Tell me if that helps


Comment below rating threshold, click here to show it.

ImmaPwnYouGood

Junior Member

11-20-2013

I have tried all of the suggestions to no avail. It didn't have any problems at all running smoothly until 2 days ago. and now my fps drops to the 30's. It's so jumpy and choppy. I CAN'T play until it gets fixed.


Comment below rating threshold, click here to show it.

SegamanGenesis

Junior Member

03-13-2014

Same issues for me. I've played with the settings and its all to no avail. I can't be in team fights anymore because things are so god damn choppy my abilities dont even go off... this is such bs because I was dumb enough to put well earned cash into this game when it was working. Now it seems I can't even play it anymore... such a piss off. This needs to be fixed... please someone help us out here.