Mac Client will NOT open

First Riot Post
Comment below rating threshold, click here to show it.

Cliffjumperr

Junior Member

10-01-2013

Also running X.6.8, and client was closing when I clicked the "Play" button like everyone else in the thread. Didn't matter whether I launched from the dock or from the app in the Finder. I tried the fast-clicking solution a dozen times, and one time it actually worked. Who knows?


Comment below rating threshold, click here to show it.

daFilex

Junior Member

10-01-2013

10.6.8 running from Finder Application Folder


Comment below rating threshold, click here to show it.

Rahixihu

Junior Member

10-01-2013

My client won't open. I just patched it and agreed to the terms and when the big "PLAY" button comes up, I click it, and the program closes... what do I do....


Comment below rating threshold, click here to show it.

Josh Kun

Junior Member

10-01-2013

Help, same problem here


Comment below rating threshold, click here to show it.

Rugby Rocket

Junior Member

10-01-2013

Can't play game. I installed the new Patch 3.12. Mac Client LOL won't open now. After 20 attempts like mentioned to reclick PLAY still won't work.

I have MAC OS 10.6.8 2 X 2.8Ghz Quad-Core Intel Xeon (Jan 2008), 16gb 667Mhz RAM.


Comment below rating threshold, click here to show it.

Col Frogfoot

Member

10-01-2013

http://forums.na.leagueoflegends.com....php?t=3909987
this works guys. im on 10.6.8 and its because we use to have userkernel, lol launcher, lolclient, all open to run our league, but tis new patch, one of those dont open (only two open) so this activates the third i guess. but just click the icon and put the [play button beside it to do so


Comment below rating threshold, click here to show it.

Rugby Rocket

Junior Member

10-01-2013

Can't play on mac os 10.6.8


Comment below rating threshold, click here to show it.

YHCAEL

Junior Member

10-01-2013

Quote:
Originally Posted by Auronis A View Post
Hey all try this fix:

http://forums.na.leagueoflegends.com....php?t=3909987

Ok guys I hope this will work out for you also. I found this way to make the game launch while I was trying to "spam" like other people said but it wasn't working for me. So I did these steps:

1. Drag the LoL icon from finder-application on your dock
2. Open LoL with that icon
3. Press play
4. Click super fast on the LoL icon you pressed on step 2
5. Enjoy

Don't close LoL before there is a real fix
i felt dumber for trying this, and beyond stupid when it worked first attempt.

upvotes for days lol.


Comment below rating threshold, click here to show it.

Rakton

Junior Member

10-01-2013

I was having the same problem on two different computers, but when i let it sit for about a minute and then pressed play it worked for me, im currently using 10.6.8 just like the rest of you.
Im not sure if it is a permanent fix for i had just done it once, but let your launcher sit for a little, about a minute and it should work as it did for me


Comment below rating threshold, click here to show it.

ssunflash

Junior Member

10-01-2013

Quote:
Originally Posted by Auronis A View Post
Hey all try this fix:

http://forums.na.leagueoflegends.com....php?t=3909987

Ok guys I hope this will work out for you also. I found this way to make the game launch while I was trying to "spam" like other people said but it wasn't working for me. So I did these steps:

1. Drag the LoL icon from finder-application on your dock
2. Open LoL with that icon
3. Press play
4. Click super fast on the LoL icon you pressed on step 2
5. Enjoy

Don't close LoL before there is a real fix


This worked for me. I don't know how. I am also running 10.6.8.