Question about Mac client's future

First Riot Post
Comment below rating threshold, click here to show it.

MalikCaesar777

Senior Member

08-24-2013

Hi, so I was wondering if at any point we will need to update our OS to be able to play on the mac client/receive updates.

I know some games require you to buy a new OS in order to keep getting updates and I was curious if this will happen to league in the near future.

Thanks in advance for your time.


Comment below rating threshold, click here to show it.

thenicksolo

Member

08-24-2013

I'd assume this would only be in the way of a MAJOR client overhaul. Most system requirements are more or less set in stone once a game has "shipped"

I mean eventually will someone have to upgrade from 10.6.8?
Yeah probably, at least on a long enough timeline, but I doubt this game will have super strict client requirements. Most people play on low settings.


Comment below rating threshold, click here to show it.

FreakinUnoriginl

Senior Member

08-24-2013

While there are a number of potential improvements to the way fullscreen gameplay is handled on Lion or better, Snow Leopard is kind of like the Windows XP of Mac OS X: despite being from 2007, and an update to Lion/Mountain Lion being fairly inexpensive, it's still the OS on about a quarter of Macs. There would need to be a lot of post-Snow Leopard features being implemented, I think, to make them require Lion or better. Or Snow Leopard user base would need to shrink significantly.


Comment below rating threshold, click here to show it.

Brentmeister

Associate Software Engineer

08-27-2013
1 of 1 Riot Posts

We have not run into a compelling reason to stop supporting 10.6.8. I wouldn't worry about us dropping support for 10.6.8 anytime soon.


Comment below rating threshold, click here to show it.

acrid56

Senior Member

08-29-2013

at least wait long enough for me to save the 2k dollars i neeed for a new mac:P (and 500 for upgrades) or soketghing like that