Welcome to the Forum Archive!

Years of conversation fill a ton of digital pages, and we've kept all of it accessible to browse or copy over. Whether you're looking for reveal articles for older champions, or the first time that Rammus rolled into an "OK" thread, or anything in between, you can find it here. When you're finished, check out the boards to join in the latest League of Legends discussions.

GO TO BOARDS


Downloaded BUT WON'T OPEN. PLEASE HELP

1
Comment below rating threshold, click here to show it.

kgmlu58242

Junior Member

08-18-2013

I've already downloaded LoL. I dropped the icon into the Applications folder already. But whenever I try to open LoL, a window keeps popping up saying League of Legends has quit unexpectedly. Giving me the options to "Ignore", "Report", or "Relaunch". But it doesn't work.
One possible reason for it not working might be my OSx version (10.5.8) I have been trying to find an update online, but none work. If anyone can help, I would be so grateful. My laptop quit on me and I can't even open up google chrome.
Thank you to whomever can help


Comment below rating threshold, click here to show it.

Purple Yi

Junior Member

08-19-2013

Lolpbe → (xp)d


Comment below rating threshold, click here to show it.

kgmlu58242

Junior Member

08-19-2013

Quote:
Purple Yi:
Lolpbe → (xp)d



I really need to play. ahaha lol pbe doesn't work either.


Comment below rating threshold, click here to show it.

FreakinUnoriginl

Senior Member

08-21-2013

Quote:
kgmlu58242:
One possible reason for it not working might be my OSx version (10.5.8) I have been trying to find an update online, but none work.
This is the reason. Minimum requirement is 10.6.8, "Snow Leopard", which can be purchased in disk form from Apple for $19.99. < Apple store link (http://store.apple.com/us/product/MC573/mac-os-x-106-snow-leopard) > Keep in mind that you'd be updating to a four-years-old OS version. We're currently on 10.8, and 10.9 is already available for developer testing, although these versions of the OS require the App Store in order to purchase the upgrade, and if your machine currently has 10.5 then it's probably not going to run the latest version well (if at all).


Comment below rating threshold, click here to show it.

kgmlu58242

Junior Member

08-22-2013

Quote:
FreakinUnoriginl:
This is the reason. Minimum requirement is 10.6.8, "Snow Leopard", which can be purchased in disk form from Apple for $19.99. < Apple store link (http://store.apple.com/us/product/MC573/mac-os-x-106-snow-leopard) > Keep in mind that you'd be updating to a four-years-old OS version. We're currently on 10.8, and 10.9 is already available for developer testing, although these versions of the OS require the App Store in order to purchase the upgrade, and if your machine currently has 10.5 then it's probably not going to run the latest version well (if at all).

yeup. figured that much. and since it won't run that well even if i update, that just sucks. because in order to update to recent mountain lion (most recent is something that i can't remember but doesn't sound like a cat to me) i still need to update to at least 10.6. so that's a total bummer. shelling out $$$. unless someone knows of some torrent mac os x update that actually works!


Comment below rating threshold, click here to show it.

thenicksolo

Member

08-22-2013

10.6 gives you also updated adobe flash and google chrome if you use that...
there are many benefits to keeping with a supported OS.


1