Client won't open! Please Help!

Comment below rating threshold, click here to show it.

Namenloss

Senior Member

10-07-2013

Hey guys, well, my problem is that my client won't start up..Even if I try to run LoL as administrator all it does is show a black screen about the size of what the launcher would be and it quickly disappears in the time frame of just about a second.

I just installed League on the new computer I built and the first thing i tried to install was league, but after the installation I get the problem above. I've already tried the delete the Lol_Launcher in the RADS folder trick and everything. Still same problem. Any solutions guys? I would love to play League on my new computer

Specs:

-Windows 7 Home Premium

-ASUS GTX650-E-2GD5 GeForce GTX 650 2GB 128-bit GDDR5 PCI Express 3.0 HDCP Ready Video Card

-Intel Core i5-4440 Haswell 3.1GHz (3.3GHz Turbo) LGA 1150 84W Quad-Core Desktop Processor Intel HD Graphics 4600

-CORSAIR Vengeance 8GB (2 x 4GB) 240-Pin DDR3 SDRAM DDR3 1600 (PC3 12800) Desktop Memory Model CMZ8GX3M2A1600C9

-ASUS H81M-E LGA 1150 Intel H81 SATA 6Gb/s USB 3.0 uATX Intel Motherboard

P.S: Already have a thread open in the General support/Help forums but it seems a little slow and I have no replies


Comment below rating threshold, click here to show it.

Namenloss

Senior Member

10-07-2013

well bump in hopes for a solution.


Comment below rating threshold, click here to show it.

Namenloss

Senior Member

10-07-2013

bump


Comment below rating threshold, click here to show it.

Namenloss

Senior Member

10-07-2013

bumping