Welcome to the Forum Archive!

Years of conversation fill a ton of digital pages, and we've kept all of it accessible to browse or copy over. Whether you're looking for reveal articles for older champions, or the first time that Rammus rolled into an "OK" thread, or anything in between, you can find it here. When you're finished, check out the boards to join in the latest League of Legends discussions.

GO TO BOARDS


fps and ping fine but still lag

Comment below rating threshold, click here to show it.

zackLF

Junior Member

07-24-2013

Same thing happed to me. My game has been lagging since yesterday. i thought it was just a quick issue. But i closed all background software, and it is still lagging so hard. 200-300 pings. I cannot even play games now. Hope the Riots and fix it.


Comment below rating threshold, click here to show it.

Johnxiang

Junior Member

07-30-2013

i have same issue here plz fix it !!!


Comment below rating threshold, click here to show it.

jimlaheysadrunk

Senior Member

07-30-2013

played all day long, now screwed up again. nice job on the fix


Comment below rating threshold, click here to show it.

BlownToDeath

Member

07-30-2013

Unplugging and replugging my router fixed it for me.


Comment below rating threshold, click here to show it.

Coltongower

Junior Member

07-30-2013

Yup, essentially, this. http://www.twitch.tv/coltongower/b/438535515


Comment below rating threshold, click here to show it.

LuxMaster

Junior Member

07-30-2013

I am also having a same problem. 3 days ago, everything was still good, until today......omg.........I was lagging sooooo BAD.......my fps and ping were very low (frs around 60 and ping around 60 ), but I kept disconnecting every 2 mins, I had to leave the game and almost break the router @@.....plz help me fix it


Comment below rating threshold, click here to show it.

DarkkHP

Junior Member

08-26-2014

Quote:
TheMonkOfFunk:
I too am in Washington and my other friend here seems to have the same issue. Considering many of those who are suffering from this issue seem to be on the west coast, perhaps that's the issue?

I actually booted up my GW2 on full settings as well. Worked fine. I do agree; an actual response other than, "please post your dxdiag!" would be lovely, especially considering that was 5 days ago and Riot has been completely hush since.

Maybe they're trying to weed out the players. Those who've spent money aren't spending enough anymore. Buy some skins, and see if it works afterwards.


Nope, I'm on the east coast. Also a Comcast customer


Comment below rating threshold, click here to show it.

Idtoshi

Junior Member

10-06-2014

Before when I played League, it ran just fine. then after the recent updates it constantly lags every game. My FPS and ping is good though. so I'm kinda stuck unable to play my best......