Welcome to the Forum Archive!

Years of conversation fill a ton of digital pages, and we've kept all of it accessible to browse or copy over. Whether you're looking for reveal articles for older champions, or the first time that Rammus rolled into an "OK" thread, or anything in between, you can find it here. When you're finished, check out the boards to join in the latest League of Legends discussions.

GO TO BOARDS


3.9 Black screen after patching. RE-INSTALL did not fix.

Comment below rating threshold, click here to show it.

Bestrin

Member

07-10-2013

After patching League 3,9, this morning, I was left with nothing but a black-screen client after hitting PLAY and before being taken to the log-in screen.

Imgur link to screenshot: http://imgur.com/22bcBXg

I have gone through various help posts on this forum, starting with "The Wrenchman's Toolbox." This lead me to "Post Patch Patcher Problems" where I thoguht I found my problem.

Quote:
Aregionius:
Fixing Post Patch Patcher ProblemsGame Won't Start After I Hit the .exe / Play button

1. Try running as an admin by right clicking on the executable and selecting "Run As" and "Administrator", or by using the lol.admin.launcher.exe

2a. Delete everything inside the your RADS downloads folder (Default Path is, C:\Riot Games\League of Legends\RADS\downloads) AND
2b. Delete everything inside your RADS solutions folder ( Default Path is, C:\Riot Games\League of Legends\RADS\solutions)
2c. Restart your computer and repatch

3a. Delete the lol_air_client folder in your RADS projects folder (Default Path is, C:\Riot Games\League of Legends\RADS\projects) AND
3b. Delete the lol_air_client_config_na and the lol_launcher folders inside the RADS projects folder.
3c. Restart your computer and repatch

4a) Go to your Riot Games projects folder and open the folder with the number for the latest release (Default path is C:\Riot Games\League of Legends\RADS\projects\lol_air_client\releases\0.0. 0.###) Find the folder with the highest number (currently 0.0.0.176 as of 8/6/12)
4b) Delete the following files:
  • releasemanifest
  • S_OK
4c) Then open the Deploy folder
4d) Delete the following folders/files:
  • lib (folder)
  • ETA-INF (folder)
  • mod (folder)
  • lolclient.exe (file)
  • lolclient.swf (file)
  • locale.properties (file)
4e) Restart your LoL application and allow it to repatch

5. Double check your anti-virus settings and exceptions for League

6. Try Reinstalling - http://support.leagueoflegends.com/entries/234176-reinstalling-league-of-legends


I ran through all five steps, with plenty of restarts, to no avail, before finally removing League, Adobe Air, and Pando Media Booster, and then running the League installer. The re-install ran flawlessly, and the 90-minute patching did as well. But now I'm stuck again where I started, with a black screen.

I don't know what to try next. I have never had major problems with the League client in the past. My guess is that there is a resolution issue with the updated client, but I do not know.

Logs attached in next post.

-----------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------

UPDATE:I found a "sticky" post (http://euw.leagueoflegends.com/board/showthread.php?t=671613) on EUW forums about Patches/Launcher issues.

Quote:
Pressed Play button but login screen is black
Delete LolClient
-File is located in: *\League of Legends\RADS\projects\lol_air_client\releases\xyz\ deploy
-"xyz" is a numbered folder that can vary depending on the current version of the game. If -there is more than one folder, pick the highest number.
-Run the repair tool built into the Patcher.


I followed these steps and then restarted my computer. Now, after selecting PLAY from the launcher, the next screen doesn't even come up!

I then tried to apply the fixes mentioned earlier in the sticky post about this issue:

Quote:
Pressed Play button but login screen does not load
-Install the latest version of Adobe Air
-Install the latest version of Adobe Flash
-Install the latest version of .NET Framework
-Use the repair function built into the Patcher
-Uninstall and reinstall to a new directory


I have gone through these first four steps but do not understand this last one. Is he suggesting that I uninstall in whole League program, and reinstal it? Unfortunately, I've already done that today...


Comment below rating threshold, click here to show it.

Bestrin

Member

07-10-2013

Attaching both Launcher logs:

rads_user_kernel.log will not upload
726992

rads_lol_launcher.log

Comment below rating threshold, click here to show it.

Lord Exin

Recruiter

07-10-2013

I am having the same issue- my screen looks identical to the image posted.


Comment below rating threshold, click here to show it.

Bestrin

Member

07-10-2013

This is the first I'm hearing of anybody else having this same issue.


Comment below rating threshold, click here to show it.

Lord Exin

Recruiter

07-10-2013

I've been looking, and some people have had this issue from years past, as far back as 2011. Unfortunately, i cannot seem to find a post from them stating it was resolved.


Comment below rating threshold, click here to show it.

Reapzter

Junior Member

07-10-2013

I am having the same problem... Tried all the steps... to no avail


Comment below rating threshold, click here to show it.

Jodzilla

Member

07-10-2013

Everything worked perfectly fine last night, but after installing the patch I have the same issue. I have tried everything that I can think of and everything that I can find online. I am just glad that I am not the only person experiencing this, thought I was for a bit.

This is what happens to me.

http://imgur.com/drCM18b


Comment below rating threshold, click here to show it.

Used Spork

Member

07-10-2013

Same thing here. RE-installed and nothing


Comment below rating threshold, click here to show it.

Bestrin

Member

07-10-2013

I'm glad to be getting some attention to the issue. Has anybody had this problem in the past and had it solved?


Comment below rating threshold, click here to show it.

Lord Exin

Recruiter

07-10-2013

The most disheartening issue is that some posts I've read say this occurred for months. I hope we can find a solution quicker than that..