My league client is not launching

Comment below rating threshold, click here to show it.

VanillaMilfshake

Junior Member

07-03-2013

I've been playing since the week League was available on mac, and i have never had any problems ti'll now. My client is not launching, and I'm not sure why. It says it is unresponsive and to check my log. Anyone else having this problem? What should I do?


Comment below rating threshold, click here to show it.

Adamosaur

Senior Member

07-04-2013

I did notice that today when I clicked to start up League, nothing happened for about 20 seconds.
After waiting 15 or 20 seconds and checking activity monitor (didn't show league client as running) I clicked on the dock icon again. After about 10 more seconds it popped up saying that the client was already running, and if I wanted to quit it or cancel. I clicked cancel and the client popped up (from before).

I notice now that when I click the dock icon to open up the League client, it bounces once then stops, and takes about 10-20 seconds before the actual client opens up and displays on the screen. Not sure the cause of this or if it's my computer, but it started happening today.

tl;dr: takes 20 seconds of nothing for lolclient to open starting today, similar issue but not as severe, maybe linked.


Comment below rating threshold, click here to show it.

Venelol

Junior Member

07-04-2013

I am having the same issue. I was playing until late last night and now today the client won't even start up at all


Comment below rating threshold, click here to show it.

xExemptx

Junior Member

07-04-2013

Same issue as well. I read other ways to fix it such as replacing Userkernal and System, however neither worked. After reinstalling the game twice it still hasn't worked.

Edit: Apparently all I needed to do was restart my laptop. It's working now.


Comment below rating threshold, click here to show it.

Mirror

Senior Member

07-04-2013

Re Adamosaur and xExemptx: This is pretty common. The only workaround I've found is to try different timings - you want to click 'Okay' when it tells you another session is running, but if you do it too fast or wait too long you have to try again. I often have to do it 3 or 4 times before it works.


Comment below rating threshold, click here to show it.

Venelol

Junior Member

07-04-2013

Mirror, I don't even get that message. It moves my dock a little like it's about to open but the L logo never even shows up.


Comment below rating threshold, click here to show it.

Mirror

Senior Member

07-04-2013

Quote:
Originally Posted by Venelol View Post
Mirror, I don't even get that message. It moves my dock a little like it's about to open but the L logo never even shows up.
Sorry, there are 3 separate issues being described in this thread - I've edited my post for clarity.