Welcome to the Forum Archive!

Years of conversation fill a ton of digital pages, and we've kept all of it accessible to browse or copy over. Whether you're looking for reveal articles for older champions, or the first time that Rammus rolled into an "OK" thread, or anything in between, you can find it here. When you're finished, check out the boards to join in the latest League of Legends discussions.

GO TO BOARDS


Mac beta wont open

Comment below rating threshold, click here to show it.

Onireaper

Senior Member

03-07-2013

Quote:
ModeratelyVexed:
same problem 10.5.8

Your OS it too old, sry. all evidence points the the fact that it wont work on anything under 10.6

i have yet to see a red post on this (i could have missed it)

but from what i gather this seems to be the case.


Comment below rating threshold, click here to show it.

Saramhr

Junior Member

03-07-2013

Quote:
Gurkhas:
oh.. try this:

Drag the LoL icon to your application map, then open it from there.
It worked for me.


which one is the 'application map' you speak of? ._. are you talking about the 'launch pad'??


Comment below rating threshold, click here to show it.

SPAMTHECHAT

Junior Member

03-07-2013

Same for me and after patching my client crashed and now i have 2 files on my desktop as well as a bunch of invisible files in my finder.


Comment below rating threshold, click here to show it.

GetApples

Junior Member

03-07-2013

Ok I fixed my original LoL client that wouldn't open.

Basically I downloaded the original .dmg file, open it, drag it into application folder.
Now, DON'T overwrite your original LoL app. You should have League and League (2).
Open package contents of League (2)
Now: Contents
LOL
RADS
system
Now, for me, UserKernel was the problem. Your original League UserKernel file should have one of those paper/pencil icons instead of the league icon, meaning that somewhere along the line the UserKernel file got changed (IDK). Basically, drag and overwrite the UserKernel from League (2) onto your original League package and overwrite, which will change the icon as well.
Upon boot, splash icon for original league will now open and game will open as normal.

Hope it works for you guys.


Comment below rating threshold, click here to show it.

Dubstepic

Recruiter

03-07-2013

Thank you guys for the info. I will try to update my mac to 10.6 as soon as I can and see if it works. And again thanks you everyone.


Comment below rating threshold, click here to show it.

Apteral

Junior Member

03-07-2013

Same thing is happening to me. I'm on 10.7.5


Comment below rating threshold, click here to show it.

Tin TTT

Junior Member

03-07-2013

Quote:
Gurkhas:
oh.. try this:

Drag the LoL icon to your application map, then open it from there.
It worked for me.



it does work!


Comment below rating threshold, click here to show it.

Saramhr

Junior Member

03-08-2013

Quote:
Tin TTT:
it does work!


can some one please tell me whats this 'application map' you speak of?


Comment below rating threshold, click here to show it.

Saramhr

Junior Member

03-08-2013

Quote:
Swizzy92:
Ok I fixed my original LoL client that wouldn't open.

Basically I downloaded the original .dmg file, open it, drag it into application folder.
Now, DON'T overwrite your original LoL app. You should have League and League (2).
Open package contents of League (2)
Now: Contents
LOL
RADS
system
Now, for me, UserKernel was the problem. Your original League UserKernel file should have one of those paper/pencil icons instead of the league icon, meaning that somewhere along the line the UserKernel file got changed (IDK). Basically, drag and overwrite the UserKernel from League (2) onto your original League package and overwrite, which will change the icon as well.
Upon boot, splash icon for original league will now open and game will open as normal.

Hope it works for you guys.


I tried doing this and i got lost... i cant even see any "userkernel'' in my 'system' folder. I saw a ''rads_user_kernel.log'' 1 and 2, in the ''RADS'' folder, with paper note icons. but in my LoL 2 package content the same thing appears. :/


Comment below rating threshold, click here to show it.

GetApples

Junior Member

03-08-2013

Quote:
Saramhr:
I tried doing this and i got lost... i cant even see any "userkernel'' in my 'system' folder. I saw a ''rads_user_kernel.log'' 1 and 2, in the ''RADS'' folder, with paper note icons. but in my LoL 2 package content the same thing appears. :/


Hmm. Well you definitely aren't copy/pasting the log files. I don't know if we have/had the same problem, but for me, LoL 2 package content should have a working UserKernel application while the LoL 1 should have one that is busted. If your LoL 2 launches and tries to patch itself like normal while the first one doesn't AND my directions don't work then you might have a different problem sorry.

Basically if your system folder doesn't look like the screenshot I sent you then just follow the directions. If it does then...