Welcome to the Forum Archive!

Years of conversation fill a ton of digital pages, and we've kept all of it accessible to browse or copy over. Whether you're looking for reveal articles for older champions, or the first time that Rammus rolled into an "OK" thread, or anything in between, you can find it here. When you're finished, check out the boards to join in the latest League of Legends discussions.

GO TO BOARDS


Mouse responsiveness off, doesn't feel write.

Comment below rating threshold, click here to show it.

iFish12

Member

01-29-2013

So I played a few games on the client and yeah. The mouse the feel "off". I can't explain how, but it feels less smooth than iLoL and the Windows counterpart. I have it turned on full sensitivity and I'm getting a consistent 50-60FPS.

More importantly, moving the camera via the mouse feels weird as heck, too. It just feels off. It doesn't feel Mac like. Or Windows like. I'm really not sure how to explain in. Resistance, maybe? And jaggedly

EDIT: I haven't tried the V-sync thing, yet. I'll try that right now.

EDIT2: Well, it's not jagged anymore but it sort of still feels off. But it is a lot better with not waiting for V-sync


Comment below rating threshold, click here to show it.

risend

Senior Member

01-30-2013

Not sure if they patched it since I tested it a day or two ago, but mouse lag from the fps seems to be ok, or thats just the fps being stable at 60 now. But this is custom game only so who knows. I dont want to play a ranked game yet, the mouse still seems off.

I tried setting mouse acceleration to 0 using the program from the european thread on this topic http://euw.leagueoflegends.com/board/showthread.php?t=1015986 then changing the mouse speed in the system settings to the way i like it. Played iLOL and worked pretty good (almost to where it should be), then tried PBE Client and it feels sort of sluggish despite jacking the sensitivity to the max, takes too much effort to reach any corner of the screen from the middle. CSing becomes an epic battle with this mouse control as of now, haha.


Comment below rating threshold, click here to show it.

K1NGSL3Y

Junior Member

02-03-2013

I have the same problem and when i increase the mouse speed it is faster but it feels like the distance of the mouse doesn't increase.


Comment below rating threshold, click here to show it.

mylesrogers

Junior Member

02-04-2013

easy fix... if you have a gaming mouse, you need to get a mouse driver that mac supports... "steermouse" worked for me

http://www.macupdate.com/app/mac/19058/steermouse

It's a free trial but it will stop the laggy mouse thing forever!


Comment below rating threshold, click here to show it.

pavi132

Senior Member

02-04-2013

Mouse lag was present when I started up a game. The mouse was set to the lowest sensitivity in the options. The mouse lag seemed to be reduced as the sensitivity was increased, but it was still present at the highest sensitivity, just not as much.


Comment below rating threshold, click here to show it.

Viz

Associate Software Engineer

02-04-2013

Quote:
pavi132:
Mouse lag was present when I started up a game. The mouse was set to the lowest sensitivity in the options. The mouse lag seemed to be reduced as the sensitivity was increased, but it was still present at the highest sensitivity, just not as much.

To give you guys an update, I'm in the middle of working on a different mouse control option.


Comment below rating threshold, click here to show it.

iamriddik

Senior Member

02-05-2013

the tracking on the mouse feels inverted. if i physically move the mouse slowly, the cursor tracks incredible fast, but if i move the mouse quickly, the cursor tracks slowly.


Comment below rating threshold, click here to show it.

risend

Senior Member

02-06-2013

Quote:
Viz:
To give you guys an update, I'm in the middle of working on a different mouse control option.


Sounds awesome, thanks for the update. Looking forward to testing it out.

Edit: Just tested it again after a week. I used a program to set the mouse acceleration to 0 and it seems to be working pretty well compared to the first time I tried it out without changing the mouse acceleration to 0. Also the FPS seems to be better, will continue to test it out to see if comes back.


Comment below rating threshold, click here to show it.

Viz

Associate Software Engineer

02-06-2013

Quote:
risend:
Sounds awesome, thanks for the update. Looking forward to testing it out.

Edit: Just tested it again after a week. I used a program to set the mouse acceleration to 0 and it seems to be working pretty well compared to the first time I tried it out without changing the mouse acceleration to 0. Also the FPS seems to be better, will continue to test it out to see if comes back.

There is now an option in the More Options menu that switches between two different mouse styles. If you have Vsync turned on, we automatically use the new style and disable the option to switch. Give it a spin and see how you like it, and let me know.


Comment below rating threshold, click here to show it.

Skye Cloud

Junior Member

02-06-2013

Excellent, thanks again for all the hard work on this project Viz. The mouse issue is my only criticism with the new client, everything else is incredible.

Thanks again