Welcome to the Forum Archive!

Years of conversation fill a ton of digital pages, and we've kept all of it accessible to browse or copy over. Whether you're looking for reveal articles for older champions, or the first time that Rammus rolled into an "OK" thread, or anything in between, you can find it here. When you're finished, check out the boards to join in the latest League of Legends discussions.

GO TO BOARDS


Video Card Does Not Support Shader 2.0

12
Comment below rating threshold, click here to show it.

BlackestEyes

Senior Member

01-21-2013

Hello, I'm having a problem with my brand new computer I just got yesterday. Everything should be working on this damn thing, but whenever I attempt to play a game of League, on start up the splash screen flashes and then it reports that the shader model 2.0 is not supported.

The computer I am on currently has a AMD Radeon HD 7450 graphics card that should support Shader model 5.0. I have run every update I can think of on my computer including the Driver software for the card and all the windows updates.

I have tried repairing League of Legends and uninstalling and reinstalling.

At this point I am pretty much out of options besides returning this computer.

The weirdest part though was that I was able to play one game last night. I played a bot game as Taric and everything seemed fine then. Nothing changed between then and the time when it started having problems.

Some help please?


Comment below rating threshold, click here to show it.

BlackestEyes

Senior Member

01-21-2013

Just tried completely uninstalling the drivers for the graphics card and reinstalling...

Still the same error.


Comment below rating threshold, click here to show it.

Solaris Shadow

Recruiter

01-21-2013

Can you attach your directx diagnostics results.


Comment below rating threshold, click here to show it.

BlackestEyes

Senior Member

01-21-2013

------------------
System Information
------------------
Time of this report: 1/21/2013, 17:44:50
Machine name:
Operating System: Windows 7 Home Premium 64-bit (6.1, Build 7601) Service Pack 1
Language: English (Regional Setting: English)
System Manufacturer: Hewlett-Packard
System Model: h8-1234
BIOS: BIOS Date: 04/17/12 13:39:40 Ver: 7.05
Processor: AMD FX(tm)-6120 Six-Core Processor (6 CPUs), ~3.5GHz
Memory: 10240MB RAM
Available OS Memory: 10006MB RAM
Page File: 3087MB used, 16921MB available
Windows Dir: C:\Windows
DirectX Version: DirectX 11
DX Setup Parameters: Not found
User DPI Setting: Using System DPI
System DPI Setting: 96 DPI (100 percent)
DWM DPI Scaling: Disabled
DxDiag Version: 6.01.7601.17514 64bit Unicode


Comment below rating threshold, click here to show it.

BlackestEyes

Senior Member

01-21-2013

------------
DxDiag Notes
------------
Display Tab 1: No problems found.
Display Tab 2: No problems found.
Sound Tab 1: No problems found.
Sound Tab 2: No problems found.
Sound Tab 3: No problems found.
Sound Tab 4: No problems found.
Input Tab: No problems found.


Comment below rating threshold, click here to show it.

BlackestEyes

Senior Member

01-21-2013

OK better idea.


Comment below rating threshold, click here to show it.

Solaris Shadow

Recruiter

01-21-2013

Go intro advanced options when posting and you can create an attachment in order to fit your entire diagnostic results.


Comment below rating threshold, click here to show it.

BlackestEyes

Senior Member

01-21-2013

Figured it out. I haven't posted on here too much.


Comment below rating threshold, click here to show it.

Solaris Shadow

Recruiter

01-21-2013

Are you running two cards? or just the one the directx has it noted that you have two cards running if so double check you crossfire settings if not then I would recommended go through removing any old drivers following this guide http://support.amd.com/us/kbarticles/Pages/GPU57RemoveOldGraphicsDrivers.aspx and then reinstalling your driver.


Comment below rating threshold, click here to show it.

BlackestEyes

Senior Member

01-21-2013

Hmm. See. I don't have that ATI program at all. I have tried to install it a few times but there is a driver there making the thing run, and the ATI thing just doesn't seem to want to run.


12