Error, Graphics card or driver does not support shader model 2.0

First Riot Post
12345678 ... 11
Comment below rating threshold, click here to show it.

Lðgic

Senior Member

09-20-2010

dan daze the driver you posted didnt work for me, said i didnt ahve the right hardware or software. im just going to downgrade back to xp, not really a big deal. its almost time for a new laptop anyways
thanks for trying to help


Comment below rating threshold, click here to show it.

Jappotea

Member

09-21-2010

this happened to my cousin as well.

alI I did was downloading the latest driver from nvidia website and the game worked again.

if u count on windows auto update, you must download it from your card official website.


Comment below rating threshold, click here to show it.

Lðgic

Senior Member

09-22-2010

my problem was my laptop is pretty old, and windows 7 did not support my old hardware/there were no updated drivers past windows vista. so turns out the problem was not with LoL but more with my system and my old craptop


Comment below rating threshold, click here to show it.

Hellax

Junior Member

09-22-2010

Hay I've got the same problem
Firstly i know that my computer is pretty bad but the game was working absolutely fine until the new patch. I get the same Shader 2.0 problem. I have a Radeon 9550 (I know its bad) and according to wiki that does support shader 2.0 so i'm stuck. is the game just trying to tell me to get a graphics cad that is a bit better or can i simple fix?


Comment below rating threshold, click here to show it.

maybelle

Junior Member

10-03-2010

Really now?This laptop was able to support WoW before I quit, now it can't support LoL,wtf?.. Ever since the new patch it's been getting errors saying" Error,Graphics card or driver does not support shader model 2.0" every time I try getting into a game ...This is quite depressing. :/. Don't know too much about technology because of my ignorant female mind, but if you find a solution, please do tell. I'd like to catch up with my now level 30 brother >.>.


Comment below rating threshold, click here to show it.

Eambo

This user has referred a friend to League of Legends, click for more information

Senior Member

10-03-2010

Go to http://canyourunit.com and Select League of Legends from the dropdown. Install the component (It wouldn't work for me in FireFox so I had to go to IE) and after the component is done run the test again. See what it says about your Pixel shader support.


Comment below rating threshold, click here to show it.

Ragazzeo

This user has referred a friend to League of Legends, click for more information

Senior Member

10-05-2010

I've been getting this error the past 5 months (My parents are divorced, so im able to play in my moms house but not in my dads house), and still haven't fixed it.

I've reinstalled-redownloaded EVERY component (LoL, Adobe Air, .net frame, graphic card drivers, Direct), but nothing had work.

I went to "http://canyourunit.com", and after the analizing, it says that my PC meets the requeriments to run LoL without problems, and still get the error.

Any ideas?
Thanks.
Ragazzeo


Comment below rating threshold, click here to show it.

TaunkaTruck

Senior Member

10-05-2010

To be honest I think is more a Riot issue than a user issue. Kind of fishy a lot of us could run the game until this new patch. I also went to canyoutunit.com as suggested:

Quote:
CPU Speed
Minimum: 2 GHz processor
You Have: 2.01 GHz Performance Rated at: 4.02 GHz
PASS

RAM
Minimum: 1 GB
You Have: 1022.4 MB
PASS

OS
Minimum: Windows XP SP2, Windows Vista SP1, or Windows 7
You Have: Microsoft Windows XP Professional Service Pack 3 (build 2600)
PASS

Video Card
Minimum: DirectX 9.0 capable video card support Shader 2.0
You Have: ATI Radeon Graphics Processor (0x7183)
PASS

Features: Minimum attributes of your Video Card
Required You Have
Video RAM 64 MB 256.0 MB
Hardware T&L Yes Yes
Pixel Shader version 2.0 3.0
Vertex Shader version 2.0 3.0


Free Disk Space
Minimum: 750 MB
You Have: 298.0 GB
PASS
I've also gone to microsoft and downloaded the most recent version of directX. I am also running the most recent video card driver, which supports up to 3.0 regarding the shader issue. This PC is half decent, though far from the best. I can play any game on this, including WoW, MoH, etc with no issue. Can someone who works for Riot explain why this is becoming a trend? It worked fine today even after the patch, I played all afternoon and even bought more riot pionts. Then suddenly I open the game again, I have to reinstall the patch that was released today, and now things magically dont work beyond the load screen. Something fishy here....


Comment below rating threshold, click here to show it.

VoidObject

Senior Member

11-03-2010

Unfortunately im having this issue as well.. For me this seems to be a universal problem with any game i try to play, which really frustrates me..

Anyway-- my guess is its a driver issue, but my one question is Anyone else having any trouble launching other games? For me LOTRO, NWN2, and of coruse LoL will not launch into games.

Thanks.


Comment below rating threshold, click here to show it.

schulzz

This user has referred a friend to League of Legends, click for more information

Senior Member

11-14-2010

just played LoL using the same VC, had my computer formatted and after downloading and installing LoL again, I got the shader 2.0 error. please help thanks


12345678 ... 11