Didn't get any of my season 2 rewards...

Comment below rating threshold, click here to show it.

WaterpipeTokes

Member

11-15-2012

Thank you Aregionius


Comment below rating threshold, click here to show it.

WarCrazy

Senior Member

11-16-2012

Quote:
Originally Posted by Aregionius View Post
Hi guys,

Certain rewards were not released at the same time and sometimes it takes a while for the system to process each reward to an individual account. If you're still missing any of your Season 2 rewards, titles or skins over the next couple of days, please make sure you submit a ticket to Riot Support here, http://support.leagueoflegends.com/a...s_requests/new and they can review your account.
Thanks for replying and letting me know something.


I have left a ticket about 3 days ago, maybe 4, no response. I understand how many they have to go through to get to mine. How long does it normally take to get your tickets answered?

I just feel THIS long after the patch, the rewards aren't going to show up. So I'm hoping I get them when riot sees my ticket or my email I sent to their support.


Comment below rating threshold, click here to show it.

WarCrazy

Senior Member

11-16-2012

bump


Comment below rating threshold, click here to show it.

WarCrazy

Senior Member

11-16-2012

bump


Comment below rating threshold, click here to show it.

Noihara

Senior Member

11-19-2012

Yea. I've sent in my support ticket concerning the issue. I've received 2 responses saying nothing helpful at all. Heres what I sent so far. This is what I sent first.

Quote:
I was 1350 ELO at the end of season 2 and I was awarded a bronze cup and no silver border on my account. A friend of mine with LESS ELO then myself got awarded silver and his border for loading into games while I was set with a bronze cup.
I'm simply trying to figure out why I was rewarded the wrong cup and no banner? Could you guys check this one for me?
First response.

Quote:
Greetings Summoner,
Thank you for contacting me! I would be happy to clarify the way Season 2 borders and badges were applied.
When playing ranked, your loading screen border trim will only show up when you are playing in the ranked queue from which you earned them. In other game modes, the border that you earned in ranked solo queue will be shown. Regardless of game mode, your border trim will only be displayed to your allies.
For more information, please see the following post by Yegg in General Discussion: http://na.leagueoflegends.com/board/....php?t=2744128
Donít hesitate to let me know if you have any additional questions. Best of luck on the Fields of Justice!
Second reply from me.

Quote:
That isn't what I meant. I didn't RECEIVE the proper Icon award or the border on my loading screen. I earned silver for season 2 but didn't get the rewards for it. I just want to know why since the friend I duo Q'd with it received the silver rewards when my ELO was higher then his at the end of season 2 and I did not. Right now all I have for Icon selection is bronze, and I was silver (1350) to be exact. I just would like to get the proper display and rewards is all I'm askin for.
Hope to see a reply soon! thanks
Second support reply

Quote:
Hello again,
I understand your frustration, but these requirements were put in place to maintain the integrity of ranked teams and queues. We did this to mitigate any abuse to ratings and rewards that could result from people joining teams.
If you have any further questions, a Season 2 FAQ is being updated and discussed at the following link:
NA: http://na.leagueoflegends.com/news/s...atings-changes
EUW: http://euw.leagueoflegends.com/board...d.php?t=901872
EUNE: http://eune.leagueoflegends.com/boar...d.php?t=498420
I've sent this last reply and still hoping to see this fixed.

Quote:
I'm confused. I MET the requirements for this. Me and my friend Duo Q'd together and that's how I GOT to the requirements yet he received the silver rank. I DIDN'T and I was higher then him in ELO. I was not given the proper rewards is what is going on. I made 1350 in SOLO/DUO Q. I didn't receive the silver reward icon or border for loading and was given bronze. I don't see what is hard to figure out about this. I was not awarded the silver rank that I earned and I don't know what else to say. It's not that hard to look at my prior stats, which exist somewhere, and see that i'm not lying. Please check my account and find out what is going on?

I didn't play much ranked last season, but I DID earn silver and I'm a bit dissapointed that I have absolutely nothing to show for it while others who were at the same ELO as me or LOWER, have gotten the rewards. So yes, I am frustrated a bit.
First time Riot has legitimately let me down I think. Kinda sad.


Comment below rating threshold, click here to show it.

StarScream991

Junior Member

11-20-2012

ive sent a ticket about this issue as well i was gold in 5vs5 premade with my team all of them got the rewards but i didnt...i won more than 5 games with the team so i was eligible the guy from support answered and said my team had an elo of 1370 so thats why i didnt get rewards so i sent him a picture showing my team was 1570 elo and that the info he provided me was wrong and besides that my teammates got their rewards so....all he said was " i cant help you with your issue i will send this request to a specialist" and i've been waiting for 4 days now...


Comment below rating threshold, click here to show it.

Noihara

Senior Member

11-20-2012

Yea. Just got my 4th automated response from ol' riot support.

so unhelpful. All they did was link me AGAIN for the 4th time to that useless FAQ thread.

Can't fix Riots mistake by lookin for my own though. Just sayin.


Comment below rating threshold, click here to show it.

WarCrazy

Senior Member

11-21-2012

Quote:
Originally Posted by StarScream991 View Post
ive sent a ticket about this issue as well i was gold in 5vs5 premade with my team all of them got the rewards but i didnt...i won more than 5 games with the team so i was eligible the guy from support answered and said my team had an elo of 1370 so thats why i didnt get rewards so i sent him a picture showing my team was 1570 elo and that the info he provided me was wrong and besides that my teammates got their rewards so....all he said was " i cant help you with your issue i will send this request to a specialist" and i've been waiting for 4 days now...
I feel bad for you, reading that, I don't think you'll get anywhere. Sorry.