Why are the champions all white?

First Riot Post
Comment below rating threshold, click here to show it.

Delaunay

Junior Member

09-27-2010

So I loaded up my first game on the beta and all the champions and the turrets, and inhibitors are completely white. Is this a problem with my computer or with the installation or the beta itself?

If it's my set up some help would be appreciated. This is what I am running on:

Model Name: MacBook
Model Identifier: MacBook3,1
Processor Name: Intel Core 2 Duo
Processor Speed: 2.2 GHz
Number Of Processors: 1
Total Number Of Cores: 2
L2 Cache: 4 MB
Memory: 1 GB
Bus Speed: 800 MHz
Boot ROM Version: MB31.008D.B00
SMC Version (system): 1.24f2
Serial Number (system): W8743AXBZ64
Hardware UUID: 33F7F926-2DD6-51EA-B5E3-E14A41A9A66C
Sudden Motion Sensor:
State: Enabled

It's not the latest macbook but it runs other online games (like wow) fine. Any advice?

Thanks!


Comment below rating threshold, click here to show it.

Warbéar

Senior Member

09-27-2010

The mac client is buggy as hell, I guess wait for an update. The only graphical issue i have is Morde and others not loading fully.


Comment below rating threshold, click here to show it.

Delaunay

Junior Member

09-28-2010

well I am going to try reinstalling. I'm trying to find more info online but there isn't much. I hope it's not my video card I will be so bummed if there is no way I can play lol on my mac.


Comment below rating threshold, click here to show it.

Udyr

eCommerce Manager


Follow Udyr on Twitter

09-28-2010
1 of 1 Riot Posts

Which graphics card do you have?


Comment below rating threshold, click here to show it.

Velkorious

This user has referred a friend to League of Legends, click for more information

Senior Member

09-28-2010

This happened to me when I first tried the mac client on my macbook, with all the settings on very high.

Within the first 5 seconds I turned everything down to very low, and I haven't had the problem since.

This was on an NVIDIA GeForce 9400. I'll test the high settings next time I play to see if that's really the issue.


Comment below rating threshold, click here to show it.

Delaunay

Junior Member

09-28-2010

Video Card Info:

Intel GMA X3100:

Chipset Model: GMA X3100
Type: Display
Bus: Built-In
VRAM (Total): 144 MB
Vendor: Intel (0x8086)
Device ID: 0x2a02
Revision ID: 0x0003

How do you adjust the settings to low?


Comment below rating threshold, click here to show it.

Velkorious

This user has referred a friend to League of Legends, click for more information

Senior Member

09-28-2010

Click the gear in the bottom-right corner and then choose "Video"


Comment below rating threshold, click here to show it.

Delaunay

Junior Member

09-28-2010

Thanks!

I will test that as soon as I finish reinstalling


Comment below rating threshold, click here to show it.

Delaunay

Junior Member

09-29-2010

That fixed the problem perfectly!! Thanks!


Comment below rating threshold, click here to show it.

dexstar

Senior Member

10-01-2010

Yea, i had a similar problem. I changed the video settings all to low and now the champs look clearer, but the shadows dont (which i dont care as much).