Strange Lag Spikes

First Riot Post
Comment below rating threshold, click here to show it.

WarpedMonkey

This user has referred a friend to League of Legends, click for more information

Senior Member

02-14-2011

Is this going to be solved any time soon, it's not like there's only one person in here getting massive lag spikes with DCs while on wireless.


Comment below rating threshold, click here to show it.

Angelgrave

This user has referred a friend to League of Legends, click for more information

Senior Member

02-15-2011

/bump


Comment below rating threshold, click here to show it.

furi0us angel

This user has referred a friend to League of Legends, click for more information

Junior Member

03-16-2011

After updating League of Legend latest Patch 1.31.27 i have been experiencing game lag.It lags so much that is unplayable.Screen freezes,not able to move.

I thought all i need is to restart the League Of Legend but when i restarted LOL and reconnected the game. "Emblem of Valour" in my inventory is showing "Elixir of Fortitude",which i cannot cosume and lag remain the same.

I played three ranked games and the lag is still there.I turn off my antivirus and firewall ,but no help.Before this patch everything was fine.

Please do something


Comment below rating threshold, click here to show it.

furi0us angel

This user has referred a friend to League of Legends, click for more information

Junior Member

03-17-2011

Lag is killing me.I cannot play a single game without a lag.
Even when i create own game and play with computer it still lag. I reinstalled LOL but lag is still there.
all these weird lag is happening just after the new patch version 1.31.27.Before this patch everything was fine.


PLEASE DO SOMETHING ABOUT THIS CRAZY LAGGGGGGGGGGG.................


Comment below rating threshold, click here to show it.

renticletape

Senior Member

03-17-2011

The problem is and isn't really LoL's fault. It has partly to do with unreliable connections. Even if your connection is fast, and pings are low, sometimes if packets are delayed or sent out of order, they can screw up this game really badly (cause loss of character control, desynchronization and other nasty lag problems). This isn't always an issue with a local area network, but also could occur in the wide area network within the ISP or within other servers. Other online games can handle this issue fairly well, hence why I don't get lag in other games while LoL can lag severely on the same connection.

I think LoL's netcode needs to be reworked to be more robust to deal with unreliable or out of order packets and packet loss. My suspicion (as I have experience with network programming in games) is that the game assumes thats the packets sent from the server are going to be received in the same order they were sent in. In games, if this isn't handled properly, can cause very weird glitches and laggy behavior similar to what I experience in LoL games.


Comment below rating threshold, click here to show it.

reefine

Member

05-09-2011

experiencing this lag ever since the patcher update.. was fine before!


Comment below rating threshold, click here to show it.

Icy0406

Junior Member

05-12-2011

http://www.youtube.com/watch?v=MEXL52cgwN4

here is my video, if you check at least these two times (5:01 and 9:30). These are just two examples of my problem which seems to be what everyone else is having trouble with as well.

I've tried different drivers, different settings and such but no luck.

Anything else i can provide just let me know.

thanks


Comment below rating threshold, click here to show it.

NixonTek

This user has referred a friend to League of Legends, click for more information

Junior Member

09-25-2011

I'm gonna hop in here and revive this thread, this issue has started happening for me since the last update. The other videos show exactly what I'm experiencing, here's my specs:

Operating System: Windows 7 Home Premium 64-bit (6.1, Build 7600) (7600.win7_gdr.110622-1503)
Language: English (Regional Setting: English)
System Manufacturer: Dell Inc.
System Model: Studio XPS 1645
BIOS: Ver 1.00 BIOS A13 PARTTBL
Processor: Intel(R) Core(TM) i7 CPU Q 720 @ 1.60GHz (8 CPUs), ~1.6GHz
Memory: 8192MB RAM
Available OS Memory: 8180MB RAM
Page File: 3260MB used, 13099MB available
Windows Dir: C:\Windows
DirectX Version: DirectX 11
DX Setup Parameters: Not found
User DPI Setting: Using System DPI
System DPI Setting: 120 DPI (125 percent)
DWM DPI Scaling: UnKnown
DxDiag Version: 6.01.7600.16385 32bit Unicode

Card name: ATI Mobility Radeon HD 5730
Manufacturer: ATI Technologies Inc.
Chip type: ATI display adapter (0x68C0)
DAC type: Internal DAC(400MHz)
Device Key: Enum\PCI\VEN_1002&DEV_68C0&SUBSYS_02FE1028&REV_00
Display Memory: 4079 MB
Dedicated Memory: 1012 MB
Shared Memory: 3067 MB
Current Mode: 2048 x 1152 (32 bit) (60Hz)

Also, my internet speeds according to Speedtest.net:
14ms ping to isp
12.46 mbps D/L
3.75 mbps U/L


Comment below rating threshold, click here to show it.

NixonTek

This user has referred a friend to League of Legends, click for more information

Junior Member

09-25-2011

Bump. This is a pretty serious bug, and I've never experienced it prior to the Riven patch.


Comment below rating threshold, click here to show it.

Iheartazns400

Senior Member

09-25-2011

fffffffffffix it