Welcome to the Forum Archive!

Years of conversation fill a ton of digital pages, and we've kept all of it accessible to browse or copy over. Whether you're looking for reveal articles for older champions, or the first time that Rammus rolled into an "OK" thread, or anything in between, you can find it here. When you're finished, check out the boards to join in the latest League of Legends discussions.

GO TO BOARDS


Bug- Greater Quintessence of the Deadly Wreathe Not Working

Comment below rating threshold, click here to show it.

Shd

Member

09-18-2012

Fixed on the patch today, finally!


Comment below rating threshold, click here to show it.

The Parasomniac

Senior Member

09-18-2012

No, this hasn't been fixed at all. I just tested it, and the Quints still do not work.


Comment below rating threshold, click here to show it.

Shd

Member

09-18-2012

It's fixed on the Brazilian server at least. Just tested the Razer movespeed quints.


Comment below rating threshold, click here to show it.

kirby145x

Senior Member

09-18-2012

When is this fixed can't play without runes.


Comment below rating threshold, click here to show it.

The Parasomniac

Senior Member

09-18-2012

Still nothing on NA server. So sad considering a patch was just released.


Comment below rating threshold, click here to show it.

caspian2012

Junior Member

09-18-2012

Guys I think the runes are fixed now. Go check yours and if they are indeed, have fun!


Comment below rating threshold, click here to show it.

The Parasomniac

Senior Member

09-18-2012

I just checked mine again. Still not working.


Comment below rating threshold, click here to show it.

caspian2012

Junior Member

09-18-2012

Quote:
The Parasomniac:
I just checked mine again. Still not working.


That is weird. My quints of sugar rush is working now. Played ARAM with the quints and I do get bonus movement speed.


Comment below rating threshold, click here to show it.

crzymdscntst

Senior Member

09-18-2012

Just tested 1 Greater Quintessence of the Greater Wreath out in a custom game and it was working.

I'd like to say they're fixed, but I can't be entirely certain across the board.

Try taking the runes that are special edition into a custom game, make it private and add a password. Have nothing but the special edition runes and a blank mastery page. Did you gain the stats? Check the champion readout in the bottom right, it's the helmet button. It will display the Bonuses to Defense Pen. Also check the stats in the bottom left, if you have the movespeed ones, the number will display green, hover over it to see if it's actually a modded value of the base.


Comment below rating threshold, click here to show it.

The Parasomniac

Senior Member

09-19-2012

This appears to now be working for me as of this morning.