Sound Looping-ooping-ooping-ing-ing-g-g-g...

Comment below rating threshold, click here to show it.

Duarack5

Senior Member

06-16-2012

This problem has persisted since I downloaded the game, but only with character voices. Some voices will work well for a few seconds, but the sound will always start to skip and loop. This best I can describe it is as:

"Welcome-come-come-m-m to Summoner's Rift-ift-ift-ift-t-t-t-t."
"It will take only a spark-ark-ark-ark-k-k of my magic to end you-ou-ou-u-u-u!"

Attack sounds/voices like Warwick's howl and Trundle's "blargh!" sounds are fine, but actual character voices seem broken for me. Has anyone else experienced this?


Comment below rating threshold, click here to show it.

Ansate

Senior Member

06-16-2012

I get it a lot. It's quite annoying and accompanies lag in this game.


Comment below rating threshold, click here to show it.

Duarack5

Senior Member

06-16-2012

This could be a problem with my computer itself, seing as the same thing happened with character voices on Portal 2 as well.


Comment below rating threshold, click here to show it.

timmy22

Member

06-20-2012

I think it has to do with lag and your computer. My computer is very bad and barely runs the game and it happens to me. My brother's computer is much better and since he's been in Germany the last few weeks I've been playing on his computer and have never experienced it on his computer.

Might be time to upgrade


Comment below rating threshold, click here to show it.

wLegend

This user has referred a friend to League of Legends, click for more information

Junior Member

10-19-2012

I had the same problem and i solved it buying a new power suply, go to the BIOS and check voltages.

Orange = 3.3 V

Red = 5 V

Yelow = 12 V

In my old powersuply i had lower voltages than the correct numbers

e.g.

3.3v shows 3.0v

5v shows 4.8v

12v shows 11.75v.