Welcome to the Forum Archive!

Years of conversation fill a ton of digital pages, and we've kept all of it accessible to browse or copy over. Whether you're looking for reveal articles for older champions, or the first time that Rammus rolled into an "OK" thread, or anything in between, you can find it here. When you're finished, check out the boards to join in the latest League of Legends discussions.

GO TO BOARDS


Install Error

123
Comment below rating threshold, click here to show it.

Vaporius

Member

10-28-2009

After reading through the forums a bit, using the forum search option, redownloading (twice) the installer, and waiting about 30 hours for an email response, I figured I'd post my problem here too:

InstallShield Wizard:
An error (-5001 : 0x80070002) has occurred while running the setup.
Please make sure you have finished any previous setup and closed other applications. If the error still occurs, please contact your vendor: .

Under the Details tab:
Error Code: -5001 : 0x80070002
Error Information:
>SetupNew\setup.cpp (142)
PAPP:
PVENDOR:
PGUID:
$
@Windows XP Service Pack 2 (2600)
IE Version: 7.0.5730.13


Any help, assistance, or other advice, would be helpful.


Comment below rating threshold, click here to show it.

Jesse Perring

Recruiter

10-28-2009

Please update Windows to Service Pack 3. If the problem persists, if I could ask you to attach your dxdiag to this forums post that would help determine the problem.

Thanks for reporting.


Comment below rating threshold, click here to show it.

Vaporius

Member

10-28-2009

Attached is the DxDiag text file for reviewing.


Comment below rating threshold, click here to show it.

Akaidian

Junior Member

10-29-2009

Having same problem. I have Fully updated Windows 7 professional.

Error Code: -5001 : 0x80070002


Comment below rating threshold, click here to show it.

reapermaster

Senior Member

10-29-2009

akaidian please make sure when you install it that you are right clicking on the installer and selecting run as administrator.

Vaporius, please install XP SP3 through windows updates or can be downloaded directly at http://www.microsoft.com/downloads/details.aspx?FamilyId=5B33B5A8-5E76-401F-BE08-1E1555D4F3D4&displaylang=en


Comment below rating threshold, click here to show it.

Akaidian

Junior Member

10-29-2009

I ran as admin. But still same error code.

Ive tried running it many ways. Still same error code. Could it be Win 7 issue. My vid card drivers are up to date as well and i am not using SLI.


Comment below rating threshold, click here to show it.

reapermaster

Senior Member

10-29-2009

have you tried redownloading the installer? I know its a little bit of a stretch, but its possible that the download was corrupted..


Comment below rating threshold, click here to show it.

Vaporius

Member

10-29-2009

As this error, aparently, happens on more than just my OS (as is evident by Akaidian having issues with Win7), I can rule out needing to devolve my OS to SP3. Any other points of advice to check for my side?

I can also rule out administrator, too, if it helps; my current (and only) login to Windows is the Administrator account, which was renamed to something other than Administrator.

Any other help, outside of suggestions to downgrade my machine to SP3, would be helpful.


Comment below rating threshold, click here to show it.

reapermaster

Senior Member

10-29-2009

xp sp3 is one of the min requirements for the game. You are running sp2.

if you are worried about sp3, most users actually get better computer performance once its installed.


Comment below rating threshold, click here to show it.

Vaporius

Member

10-29-2009

I am aware that it lists SP3 as a "requirement", but with the installer from that "upgrade" updated on my machine (as it was released as a stand-alone update from MS), there is no change.

Can you, reapermaster, or someone else at Riot, tell me what specifically LoL is calling that would actually make an SP3 requirement, or is it a case of "we wrote it on SP3/Vista SP1/7, therefor that's the requirements, even if it uses nothing but calls from XP base"?


And as an amusing side note, looking up the error code on Google, this thread shows up on the first page of hits (as of 10:35 AM Pacific)


123