Welcome to the Forum Archive!

Years of conversation fill a ton of digital pages, and we've kept all of it accessible to browse or copy over. Whether you're looking for reveal articles for older champions, or the first time that Rammus rolled into an "OK" thread, or anything in between, you can find it here. When you're finished, check out the boards to join in the latest League of Legends discussions.


League of Legends WORKING on Linux

Comment below rating threshold, click here to show it.


Junior Member


everything ran good up until i tried to get into a game. I went through a queue, chose character, and all, but nothing happens when the loading screen is supposed to come up. Also ie6 404's. not sure if that's related.

Another thing i get when the loading screen is supposed to come up, is this
"Microsoft Visual C++ Runetime Library
Assertion failed!

Program: ...
Frile: C:\Jenkins\workspace\New-code-CI-...\NetCoreEnet.cpp

Expression: false

For Information on how your program can cause an assertion failure, see the visual C++ documentation on asserts

(Press Retry to debug the application - JIT must be enabled)"
There is a button for abort, retry, ignore. None do anything to help

Comment below rating threshold, click here to show it.


Junior Member


If you want to launch LoL from your desktop:
From the terminal type: gksudo gedit
In the file that opens paste (editing to include your user name):
cd "/home/[USER]/.wine/dosdevices/c:/Program Files/Riot Games/League of Legends/RADS/system"
WINEDEBUG=+ntdll wine "rads_user_kernel.exe" run lol_launcher $(ls ../projects/lol_launcher/releases/) LoLLauncher.exe
Save as "LoLLauncher.sh" in /bin/
Close the file and in terminal run:
sudo chmod a+x /bin/LoLLauncher.sh

This last part is a bit specific depending on what GUI you are using. This is for GNOME.
Then on your desktop right click and choose Create Launcher
Under Name, type League of Legends.
Under Command, type /bin/LoLLauncher.sh
Enter Comment
Finally Click OK

Or you can just run LoLLauncher.sh from the terminal.

Comment below rating threshold, click here to show it.


Junior Member


OMG this got it patching for meeeee will update when I get ingame/finish game <3<3 PROPS 2 U MY FRIEND.

okay works 100%

I believe I have videocard issues though I've got black boxes and low framerates any suggestions?

Comment below rating threshold, click here to show it.


Senior Member


Other guides also said that it didn't perform as well (lower framerate) on Linux as it does on Windows - did you experience the same, or was it equal? I don't technically meet the minimum requirements for League, but it's still playable at around 15 FPS when I can get Windows to work. Just wondering if it'd be around the same on Ubuntu, since 15 is about as low as I could go and enjoy the game.

Comment below rating threshold, click here to show it.

Lord Nietzsche

Junior Member


wine --version: wine-1.4
NVIDIA Driver Version: 280.13

The launcher hangs updating. Here is the console output when that happens:


But if i insist restarting, sometimes the Play button appears enabled:


When i hit Play:


Then I login succesfully:


Then I try to launch a game:


An error window pop up (i855.photobucket.com/albums/ab119/jsanchezm/err1.png ). If I hit RETRY:

wine: Unhandled exception 0x80000003 at address 0x78138848 (thread 0064), starting debugger...

Another error window (i855.photobucket.com/albums/ab119/jsanchezm/err2.png ). I hit Close:

( ERROR)[17:18:47.977] RADS::UserKernel::NamedPipe::ConnectionThread::ThreadProc: The handle that was passed to the API has been either invalidated or closed.
( ERROR)[17:18:47.978] RADS::UserKernel::NamedPipe::ConnectionThread::ThreadProc: ConnectNamedPipe failed.

The same happens if i hit Ignore in the first error window.

In the notification area there is an item that might be the launcher. It says "Game still in progress". When I close it:


I've been having this error, and have found no one that can fix it, do you know of any common fix?

Comment below rating threshold, click here to show it.


Junior Member


just a heads up, this baby didnt work for me.

code: winetricks ie6
(installs internet explorer 6)

im on the latest linux 11.10 i think

Comment below rating threshold, click here to show it.


Senior Member


I'm having issues getting into a match. Everyone loads in and then I do but it hangs at the loading screen and then crashes out.

Comment below rating threshold, click here to show it.


Senior Systems Administrator


Great tutorial, thanks for posting it. I ran through it and got everything installed ok on Ubuntu, but it's choking on my video driver. I have the proprietary fglrx graphics driver installed and enabled, although it says it's not configured properly:

err:winediag:X11DRV_WineGL_InitOpenglInfo Direct rendering is disabled, most likely your OpenGL drivers haven't been installed correctly (using GL renderer "ATI FirePro V5700 (FireGL)", version "1.4 (3.2.9756 Compatibility Profile Context FireGL)&quot.

I have a few more things I'm going to try and will report back when I have a chance. Would love to get this working.

Comment below rating threshold, click here to show it.


Senior Systems Administrator


Success, sort of. I had to remove the proprietary FGLRX driver from the System -> Administration -> Hardware drivers menu, reboot, install the fglrx driver I downloaded from the ATI web site, reboot, and then run 'aticonfig' to set a couple of things.

I then started the client, logged in, started a practice game and set my video settings as follows:

Settings: auto
Resolution: 1900x1200 (I tried a couple of settings, no improvement/degradation either way)
Windowed Mode: Borderless
Character Quality: Low
Environment Quality: Low
Effects Quality: Low
Shadows: No Shadow
Fast Terrain: checked
Frame Rate Cap: Stable
Wait for Vertical Sync: checked

I was able to achieve 32-38 fps with these settings. The play was a little choppy, and the biggest problem was while in battle the game would hang for about 2 seconds every minute or two. There may be some additional tweaks I can play with, but it's a little painful to play as it stands right now.

FWIW, I'm using a Dell Precision desktop with 4 cores and 4G RAM. Before switching out the fglrx driver, I was getting about 3900 fp5s, now with the new driver I'm getting about 14k fp5s going by glxgears.

Comment below rating threshold, click here to show it.


Junior Member


you can get better results using Oracle Virtualbox running Windows 7 as Guest OS.
I got 40FPS with all settings on Medium and without Vertical Sync

My Config:
HP Pavilion DV6 3240br
AMD Phenom N850 Triple-Core
AMD Radeon HD 6550M
Ubuntu 12.04 LTS