Welcome to the Forum Archive!

Years of conversation fill a ton of digital pages, and we've kept all of it accessible to browse or copy over. Whether you're looking for reveal articles for older champions, or the first time that Rammus rolled into an "OK" thread, or anything in between, you can find it here. When you're finished, check out the boards to join in the latest League of Legends discussions.

GO TO BOARDS


Wont let me get past all updates are complete!

1
Comment below rating threshold, click here to show it.

House Painter

Member

10-08-2009

Hey world, who can help me?

when i start up LoL it loads up the bottom, then it will say all updates complete.
But the server status, news, and community all just sit there and spin. I cant click on play at all, however i can click on options and logs. Ive been playing for a while now and never had any problems, could it be anything with my graphics card? Ive already tried to forward my ports if that does anything, and i already did all the other stuff i read on the site!

but here are my diagnostics if you need them.


Comment below rating threshold, click here to show it.

reapermaster

Senior Member

10-08-2009

.... that doesnt make alot of sence.. The news and all that is pulled from this webiste. You are able to post and obviously login from a browser.

What browser do you use?
Have you ever been able to get into a game?


Comment below rating threshold, click here to show it.

House Painter

Member

10-08-2009

i always can get into games... I'm lvl 30, and did you mean browser as in Firefox?


Comment below rating threshold, click here to show it.

reapermaster

Senior Member

10-08-2009

open IE and try to login to http://beta.leagueoflegends.com

something isnt quite right.

An alternative is to have it reload the launcher.

Quote:
If you are stuck at "Retrieving Version Information"
try renaming C:\Riot Games\League of Legends\LOL.Patcher.version
to C:\Riot Games\League of Legends\LOL.Patcher.version.bak


Comment below rating threshold, click here to show it.

House Painter

Member

10-08-2009

haha wow i feel like an idiot... but who woulda known haha. well except you!! All i had to do was set internet explorer as my default browser and now its working.... haha is there a reason why that is? But really thank you so much for you help!! really thank you!!


Comment below rating threshold, click here to show it.

Incanto

Junior Member

10-10-2009

I'm a new player and I am having same problem. After starting LoL the Launcher says: All Updates complete, however the server status, news, and community loading icons continue to spin. It won't let me start the game from this point.
I have switched my default browser to IE and it still hasn't worked. Can anyone help me?


Comment below rating threshold, click here to show it.

reapermaster

Senior Member

10-10-2009

try going through this post http://beta.leagueoflegends.com/board/showthread.php?t=15428

specifically I am interested in what the results would be from solution 4.


1