How do you Download LoL on mac?

123
Comment below rating threshold, click here to show it.

niikoweirdo3

Junior Member

03-05-2012

I only have a mac computer and am MADLY IN LOVE with LOL PLEASE i will die without playing lol


Comment below rating threshold, click here to show it.

Keyru

Player Behavior Specialist

03-05-2012

You can download a version of the LoL for Mac here:

http://boompje.net/forum/index.php?action=main


Comment below rating threshold, click here to show it.

Fevillan

This user has referred a friend to League of Legends, click for more information

Junior Member

03-23-2012

Is this allowed by Riot? Considering they didn't make it...


Comment below rating threshold, click here to show it.

Logic Hunter

Junior Member

04-06-2012

whaat version do youu need your software to be? i tried downloading it ON MY MAC it says " you cannot use this version of the application iLOL open beta with this version of MAC OS X "


Comment below rating threshold, click here to show it.

legacylegends

Junior Member

04-11-2012

i was wondering the same thing


Comment below rating threshold, click here to show it.

Yampsky123

Junior Member

04-18-2012

Does anyone know how iLol is running on the new patch as of 4/17/12 -4/18/12?


Comment below rating threshold, click here to show it.

tmc11

Junior Member

05-04-2012

boompje is back down after the spectator patch


Comment below rating threshold, click here to show it.

Hesetys

Junior Member

07-01-2012

Quote:
Originally Posted by Keyru View Post
You can download a version of the LoL for Mac here:

http://boompje.net/forum/index.php?action=main
No you can't.

You just get a link to some rapidshare **** page which wants me to participate into some **** survey etc.

Please, put the file into your own server and put a direct link into it.


Comment below rating threshold, click here to show it.

Boompje

Senior Wrenchmen

07-04-2012

Quote:
Originally Posted by Hesetys View Post
No you can't.

You just get a link to some rapidshare **** page which wants me to participate into some **** survey etc.

Please, put the file into your own server and put a direct link into it.
Then you click on a wrong link.

Try the Wrenchbox mirror. The iLoL applications needs at least 10.6.8, but OS X Lion is recommended.

This project is allowed by Riot, but not officially supported.


Comment below rating threshold, click here to show it.

capt zoom

Junior Member

07-26-2012

is allowed but not supported??? and why i can play with 10.8??? montain lion!??


123