Asus G74XS and the Nvidia 560M

12
Comment below rating threshold, click here to show it.

xVoiDx

Senior Member

08-30-2011

OK Riot


I have some questions, I just bought a G74 and it seems that it can't handle LoL on Very High settings. I get some FPS drop when there is a lot of things going on the screen. Like when pushed to the fountan and there are minions everywhere the FPS will drop.

Before my G74 I had a G73JH and it had a Ati 5870M and I never had any FPS issues on very high settings. Is this game more compatible with Ati drivers and GPUs? The 560M does benchmark higher then the 5870M. So I am at a loss here wondering why I have an FPS issue.

You can rule out any software issues all I did when I first opened it up was uninstall the anti virus then update the video card driver.

Any ideas here are the 2 links for each laptop

G74SX http://www.asus.com/Notebooks/Gaming...specifications
G73JH http://usa.asus.com/Notebooks/Gaming...specifications


Comment below rating threshold, click here to show it.

JetStreamAttack

Senior Member

08-30-2011

rich basterd D:<


Comment below rating threshold, click here to show it.

xVoiDx

Senior Member

08-30-2011

lol no I wish I was rich, I got my G73 from bestbuy and got their Geek Squad plan and the motherboard when out on it. So they sent it out for repair and said they could not get parts so they gave me the closest thing to my G73 they were selling.......and it was the G74 .


Comment below rating threshold, click here to show it.

NostalgicGamer

This user has referred a friend to League of Legends, click for more information

Senior Member

08-30-2011

I have Vista Home Premium 3GB of ram, 32 Bit and I lag when Noc/Orianna is in the game- Riot is just bad at coding... P.S. 62FPS without noc/ori 100% of the time.


Comment below rating threshold, click here to show it.

Fish

This user has referred a friend to League of Legends, click for more information

Senior Member

08-30-2011

solution: Don't play on very high settings.


Comment below rating threshold, click here to show it.

Ezozel

Senior Member

08-30-2011

Well, first of all, you can't rule out all software problems just because you uninstalled antivirus and other stuff off the machine when you got it. You may not be running the correct and up to date drivers or maybe the updated drivers are causing problems with LoL for some reason. It COULD be related to the FPS bugs that some people are having but IIRC it was stated that only a certain set of RADEON cards were having issues, not Nvidia.

I have a G73SW myself and it's running the GTX460M with everything capped in borderless mode, no issues. The 560M is essentially the same card with a few tweaks here and there so you shouldn't be having issues yourself.

Personally, I would nuke the entire machine and do a clean Win7 install because the Asus G Series comes with a fair amount of bloat. Doing a clean install yourself fixes a myriad of problems and allows you to make absolutely certain that the correct drivers and applications are installed.


Comment below rating threshold, click here to show it.

YoungUnicorn

Senior Member

08-30-2011

Shadow's usually do it for me, disable shadows and your FPS will increase by like 20.


Comment below rating threshold, click here to show it.

Ezozel

Senior Member

08-30-2011

Also, one last thing worth noting is that you need to plug that machine in in order to take full advantage of the GPU. If you unplug it then you lose quite a large chunk of performance since the battery can't support the card running at full load.


Comment below rating threshold, click here to show it.

Flow Nekcuf

Senior Member

08-30-2011

Quote:
Originally Posted by Keitau View Post
Through all the specs, I failed to see an actual video card on that laptop. That could be your problem, on board cards usually have fairly low in card ram. And notice the older one does have a 3/2 g video card.
NVIDIA? GeForce? GTX 560M with 3GB/2GB GDDR5 VRAM


Comment below rating threshold, click here to show it.

RadGH

Junior Member

08-30-2011

The G73jh comes with power4gear hybrid, which you can use to change your CPU performance for power saving/performance boosting purposes. Maybe the G74 of yours has this (or a similar utility) which has it set to a power-saving mode, causing the poor performance?

This is what I expect, assuming your drivers are all up to date and you aren't doing something stupid (like defragmenting as you play).


Quote:
Originally Posted by Dafishies View Post
solution: Don't play on very high settings.
Not a solution, but a workaround. Good try, smartass


12