Welcome to the Forum Archive!

Years of conversation fill a ton of digital pages, and we've kept all of it accessible to browse or copy over. Whether you're looking for reveal articles for older champions, or the first time that Rammus rolled into an "OK" thread, or anything in between, you can find it here. When you're finished, check out the boards to join in the latest League of Legends discussions.

GO TO BOARDS


Problem with black screen

123
Comment below rating threshold, click here to show it.

skimmer

Junior Member

09-09-2009

When I enter the game the background and heroes are all black. I can see only hud, lifebars and some special effects (flying projectiles, auras, etc) otherwise I can't see anything.

I've been told that usualy this can be solved by turning off AA, which I managed to do and problem still remains. My graphic card also should support shader 3.0 (as more advanced version than 2.0 I guess it might work) and I didn't notice any other solutions on the whole forums.

Is there something I overlooked? I would really appreciate some help.


Comment below rating threshold, click here to show it.

Crap

Member

09-09-2009

Try Rebooting.. Could also be caused by DirecX?


Comment below rating threshold, click here to show it.

Jesse Perring

Recruiter

09-09-2009

Is it the same effect on all game settings? Try turning the settings down to see if it helps the issue. Also make sure all the newest drivers and Windows updates are installed on your computer.


Comment below rating threshold, click here to show it.

skimmer

Junior Member

09-09-2009

Quote:
Crap:
Try Rebooting.. Could also be caused by DirecX?

If you mean rebooting like turn off and on computer then it didn't had any effect at all. If you mean erase and reinstal all files....well, it's not even two months since i'ts been in factory setting.

I doubt that. I even tried to download and instal the newest directX9 again and nothing changed at all.

Quote:
Jesse Perring:
Is it the same effect on all game settings? Try turning the settings down to see if it helps the issue. Also make sure all the newest drivers and Windows updates are installed on your computer.


Yes, I tried the lowest and then the highest. Then I also tried zoom, turn on and off floating text and switch between every resolutions. I also looked up the newest driver just yesterday and according to Microsoft update, I have all updates already instaled......still no change at all.

Any options left?


Comment below rating threshold, click here to show it.

reapermaster

Senior Member

09-09-2009

download and run the directx install. Could have corrupted directx install
http://www.microsoft.com/downloads/details.aspx?FamilyID=0cf368e5-5ce1-4032-a207-c693d210f616&displaylang=en

If that doesnt resolve it I would recommend uninstalling the video card drivers and re-installing them.
http://support.amd.com/us/gpudownload/windows/Legacy/Pages/radeonaiw_xp.aspx?type=2.4.1&product=2.4.1.3.13&lang=English


Comment below rating threshold, click here to show it.

skimmer

Junior Member

09-09-2009

Quote:
reapermaster:
download and run the directx install. Could have corrupted directx install
http://www.microsoft.com/downloads/details.aspx?FamilyID=0cf368e5-5ce1-4032-a207-c693d210f616&displaylang=en

If that doesnt resolve it I would recommend uninstalling the video card drivers and re-installing them.
http://support.amd.com/us/gpudownload/windows/Legacy/Pages/radeonaiw_xp.aspx?type=2.4.1&product=2.4.1.3.13&lang=English



Did both 3 times already, I even used the same pages. It must be something else....


Comment below rating threshold, click here to show it.

kuros

Senior Member

09-09-2009

yea.... i'm in the same boat on this one *tear* :'(


Comment below rating threshold, click here to show it.

reapermaster

Senior Member

09-09-2009

The only thing that I can think of is to uninstall the game. restart your PC. Ensure you have administrative rights, and re-install the game... You may have already done this, I just didnt see it in any of the previous post.

Also you may want to do what the are having the Vista and Windows 7 users do and ensure that it is not installed to "c:\Program Files"


Comment below rating threshold, click here to show it.

skimmer

Junior Member

09-10-2009

Problem solved by myself. It turns out that my graphics card is no longer supported by the newest ATI drivers which leads into direct3D fails, therefore black environment occured. Easy solution is to simply instal older ATI driver and then it should be OK.

I used version 9.1 which can be found on this (http://www.filehippo.com/download_ati_catalyst_xp/5180/) link and now the game works flawlessly.

Thank you all for your effort, it really helped.


Comment below rating threshold, click here to show it.

SolarClipz

Junior Member

09-10-2009

Maybe I should check into your solution.
I have the exact same problem :O


123