Tutorial: Running League Of Legends on Ubuntu (and other Debian derivatives)

Comment below rating threshold, click here to show it.

EOYZ

This user has referred a friend to League of Legends, click for more information

Junior Member

07-25-2011

Quote:
Originally Posted by StickyTentacle View Post
I ask because this...

http://appdb.winehq.org/objectManage...sion&iId=19141

shows all tests and whatnot to be garbage. So if he did tailor a new package why not submit it?
And does it bug out with every update? Too soon to tell?
That is rated garbage because that is for Riot's official launcher. Riot's launcher uses the RADS system which the ace client (currently) does not use. However ace client is in the process of switching their client over to RADS. When this happens, the ace client will be broken and LoL unplayable until
http://bugs.winehq.org/show_bug.cgi?id=26924 <-this bug is fixed under wine.

^Thats all assuming someone doesn't maintain the old ace cleint once they switch over to the RADS system. I dont know if they would do that though just for the sake of linux users. Idk how complicated it is to update the ace client o.O

Soooo while its great theres a work-around to get it working I'd still encourage you all to vote for the app and the bug blocking the official launcher from working. Because this may only be a temp work-around.

On a side note guys
http://appdb.winehq.org/votestats.php
LoL is one of the top 25 voted apps in the entire AppDB now!! (number 25 lol)
Considering all the programs and games that are in the AppDb thats pretty impressive

"There are 17096 applications currently in the database"


Comment below rating threshold, click here to show it.

TeeMM

Junior Member

07-25-2011

Quote:
Originally Posted by RoosterCockburn View Post
Download and install the 3.9 client, then extract the files from the 3.10 patch and copy them over to your 3.9 install folder (/home/you/.wine/drive_c/where ever you put it) and do the same for all the other patches. If there is a readme.txt or important.txt file in the patch, read it, it may have more detailed instructions. Essentially you just copy over files, thats pretty much it, but be sure to apply each new patch starting with the oldest to the newest.
Alright, I got to this point and thought I was doing everything right, but apparently not. I apologize for all the questions, but I've been at this for 7 hours now trying to get this to work, ha...

I got the 3.9 client installed, tested it, got to the login screen, everything seemed to work fine, so I moved on to the patching part. I extracted the 3.10 patch to the LoL folder in wine, then extracted the 3.11, and then the 3.12 and tried everything again, got to the login screen, and the only thing I get when I try to login is something like "client 1.36.36 not accepted by server"

I don't know where I went wrong..


Comment below rating threshold, click here to show it.

EOYZ

This user has referred a friend to League of Legends, click for more information

Junior Member

07-26-2011

Isnt there supposed to be an installer for the patches? I havent used ace client recently but I never remember extracting the patch into my game folder


Comment below rating threshold, click here to show it.

StickyTentacle

Junior Member

07-27-2011

Thanks a bunch Rooster, I spent the past three hours tinkering with WINE and the instructions and terminal, and finally got it running =D

Only to get a "client 1.36.36 rejected by server"
Anyone else have this problem?


Comment below rating threshold, click here to show it.

StickyTentacle

Junior Member

07-27-2011

I think I'm out of luck, what with the 300MB patch Riot put out yesterday.

@EOYZ thanks for the info I'll be sure to do that.

Also, bombard Riot with emails until the come up with a linux distro.

Until then I'll get plenty of practice with WINE.


Comment below rating threshold, click here to show it.

StickyTentacle

Junior Member

07-27-2011

Quote:
Originally Posted by Khimaera View Post
Still can't do this because I still can't find Software Sources :P It is an installed application according to the Ubuntu Software Center, but it doesn't show up with my other usable applications.
in case no one pointed this out, click on applications, and it should be the last option. Ubuntu Software Center. From there go to edit, and then to software sources, and you should be able to add the ppa.


Comment below rating threshold, click here to show it.

RoosterCockburn

Member

07-27-2011

Quote:
Originally Posted by StickyTentacle View Post
Thanks a bunch Rooster, I spent the past three hours tinkering with WINE and the instructions and terminal, and finally got it running =D

Only to get a "client 1.36.36 rejected by server"
Anyone else have this problem?
Hey,
I believe they're releasing a new patch for the Ace Client in accordance with the Wukong update.


Comment below rating threshold, click here to show it.

RoosterCockburn

Member

07-27-2011

Quote:
Originally Posted by EOYZ View Post
Isnt there supposed to be an installer for the patches? I havent used ace client recently but I never remember extracting the patch into my game folder
Hey,
Each patch should come with in a ZIP or RAR file. You extract those files and copy over the files into the client folder overwriting and replacing older files with their newer counterparts. I'm uploading my video tutorials today so hopefully it'll make this whole process easier.
Thanks


Comment below rating threshold, click here to show it.

WeWillEndure

Junior Member

07-28-2011

When I attempt to run the program, I encounter a program error. It says that it can be caused by a problem in the program or a deficiency in Wine. I've tried to clean install and patch this twice already, so what could be happening, and how can I fix this?


Comment below rating threshold, click here to show it.

WeWillEndure

Junior Member

07-28-2011

Is there a certain dll I need to install in winetricks or what? Please reply soon, I'm rather impatient at this point...