Server is currently busy?

Comment below rating threshold, click here to show it.

hamzathegreat

This user has referred a friend to League of Legends, click for more information

Junior Member

10-13-2011

Ty !!!


Comment below rating threshold, click here to show it.

FleaFly

Senior Member

12-11-2011

Quote:
Originally Posted by Illadelphs View Post
So after establishing that the problem does lie within IE, i finally found the fix. I use Vista as my OS, but the OS of your system should not affect this fix. Simply go into IE(does not matter what version). Scroll to the top right toolbar, and click tools. Then go to Internet options. Go over to the last tab, which is advanced, then scroll down to the Security section in settings. Uncheck the 4th and 5th box which read check for publisher and server certificate.

This will fix your problem.
OMG DUDE THANK YOU SO MUCH.
Seriously thanks to you im finally able to play again!

Add me please we dont have to play together I just want you to know you're awsome!


Comment below rating threshold, click here to show it.

grangal

Junior Member

02-13-2012

i have same frikin problem since a week ago


Comment below rating threshold, click here to show it.

DAFALLEN

Junior Member

06-09-2012

tried everything. what now?


Comment below rating threshold, click here to show it.

KamiKid

Junior Member

06-09-2012

Quote:
Originally Posted by AllenTheGreat View Post
Try doing this
(Note: These need to be done in Internet Explorer, as this is the browser that LoL relies on) -
thank you finally worked


Comment below rating threshold, click here to show it.

WeaverReaper

Junior Member

06-25-2013

Quote:
Originally Posted by Illadelphs View Post
So after establishing that the problem does lie within IE, i finally found the fix. I use Vista as my OS, but the OS of your system should not affect this fix. Simply go into IE(does not matter what version). Scroll to the top right toolbar, and click tools. Then go to Internet options. Go over to the last tab, which is advanced, then scroll down to the Security section in settings. Uncheck the 4th and 5th box which read check for publisher and server certificate.

This will fix your problem.
Thank you good sir!


Comment below rating threshold, click here to show it.

Iphq

Junior Member

08-21-2013

I had to cut off my LoLReplay to get it to work. Might be same issue with some of you.


Comment below rating threshold, click here to show it.

StalkedByDeath

Junior Member

05-08-2014

Quote:
Originally Posted by AllenTheGreat View Post
Try doing this
(Note: These need to be done in Internet Explorer, as this is the browser that LoL relies on) -
I thought this was some BS answer from some microsoft junkie trying to get me to use my InternetExplorer ... turns out resetting the IE settings works... and since I never use that anyway there was no issue with my settings for my other browser.