HALP ! "Could not load direct3d" - Loader Error !

12
Comment below rating threshold, click here to show it.

Cap0ne

Junior Member

04-30-2011

Game crashes when I double click the LoL icon, and gives me a loader error that says "Could not load direct3d."

I've uninstalled/reinstalled/updated my graphics drivers, directX, .net framework, my Window Service pack, AND LoL.. All of them atleast twice, and STILL getting this error.

When I first installed on this computer I was getting the "Pixel Shader 2.0" error, but after re-installing my graphics driver that error went away and was replaced with the error I'm posting about now.

I'm running windows xp pro, 32 bit.


Comment below rating threshold, click here to show it.

Eambo

This user has referred a friend to League of Legends, click for more information

Senior Member

04-30-2011

Can you please upload a DxDiag?

- Press Windows Key + R
- Type in 'DXDiag' and press enter
- If prompted for WHQL verification, hit yes
- Save a DXDiag to your desktop
- Select 'go advanced' below, and upload the DXDiag


Comment below rating threshold, click here to show it.

Cap0ne

Junior Member

04-30-2011

Attachment 164840


Comment below rating threshold, click here to show it.

Eambo

This user has referred a friend to League of Legends, click for more information

Senior Member

04-30-2011

If you upload it to pastebin or something just link to it :-) Copy-paste is a bit messy, too long. :-)


Comment below rating threshold, click here to show it.

Cap0ne

Junior Member

04-30-2011

Quote:
Originally Posted by Eambo View Post
If you upload it to pastebin or something just link to it :-) Copy-paste is a bit messy, too long. :-)
I edited it.

Should be good now bud !


Comment below rating threshold, click here to show it.

Cap0ne

Junior Member

04-30-2011

O.o


Comment below rating threshold, click here to show it.

Eambo

This user has referred a friend to League of Legends, click for more information

Senior Member

04-30-2011

Cap0ne, has this ever worked? It looks like you don't meet the minimum requirements for League of Legends. You can confirm this by going to http://canyourunit.com and running a test against LoL, but you don't seem to have Shader Model 2.0


Comment below rating threshold, click here to show it.

CManthe

Junior Member

05-01-2011

I'm getting the same error, but I'm trying to run LoL in a Virtual Machine. I've attached my DxDiag.txt, and when I tried the Canyourunit.com site, it told me that I didn't have a video card at all. Is there any way that I can solve this?


Note: This is one of the many solutions I've been trying in order to play such a wonderful game on my Linux based OS, Ubuntu.


Comment below rating threshold, click here to show it.

Xeuras

Junior Member

05-03-2011

Long story short, you won't be running LoL in a virtual machine unless it has d3d support (which was experimental in vmware, last I checked). Double check whether there's any d3d support for your VM, and if not, run it under wine (which was working prior to the most recent patcher update).


Comment below rating threshold, click here to show it.

b0ooo

Junior Member

05-05-2011

1. update your graphics driver.

If that doesn't work then go to 2:
2. close all videos / music that are playing in your browser or in the background.

If those dont work then go to step 3:
3. close everything and open lol.

If it still doesn't work, gg? I had the same problem, but now it works. I didn't have to do this before the new patch and I was already using the beta loader.


12