LoL Launcher issue, out of nowhere.

12
Comment below rating threshold, click here to show it.

Basque

Senior Member

02-27-2010

I've been playing LoL since the Beta days, always in Windows 7, still am.
For a couple of days, I've been having some sword of trouble with the Launcher, so, in case there was something wrong, I did absolutely EVERYTHING I read in the support stickys, even downloaded the new LoL installer. After the clean install, it worked, I played a game, closed it and now it's acting out again and I haven't the slighlest clue as to why.

Here's the problem:

Double-click launcher, opens up fine, and stops at "retrieving version information" with the Play button in gray. Everything the sticky said was checked, good, open, everything.
Now, after I've closed it and gone to do other stuff, an error pops up, stating this

Internal error
ASSERT: Pointer is NULL
(..\..\..\source\shared\patcher.c/1924)


Anything you need to solve it, just ask, since I dont know what you may need.

Just in case, I'll leave my specs:

Windows 7 Ultimate
on a
Athlon II 245
2GB DDR3 1333Mhz Kingston
ASUS M4A785TD-V EVO
Sapphire HD4670 512Mb GDDR3
Samsung 200Gb SATAII -main HDD, with Windows, programs, etc-
Seagate 750Gb SATAII -2d HDD, just files-
VTB SAN-45b -psu-



Pleeeeassse, fix it


Comment below rating threshold, click here to show it.

gotosira

Member

02-27-2010

I got the exact problem help!!!


Comment below rating threshold, click here to show it.

gotosira

Member

02-27-2010

02/28/2010 01:14 [INFO] Solid LauncherLib [1.0.0.33] initializing...
02/28/2010 01:14 [INFO] Retrieving dynamic path[http://l3cdn.riotgames.com/LOL.Produ...SourceURL.xml]
02/28/2010 01:15 [WARNING] Error retrieving [http://l3cdn.riotgames.com/LOL.Produ...SourceURL.xml] ErrorCode 950
02/28/2010 01:16 [INFO] Retrieving dynamic path[http://l3cdn.riotgames.com/LOL.Produ...SourceURL.xml]
02/28/2010 01:17 [WARNING] Unable to find package []
02/28/2010 01:17 [WARNING] Error retrieving [http://l3cdn.riotgames.com/LOL.Produ...SourceURL.xml] ErrorCode 950
02/28/2010 01:17 [WARNING] Unable to find package []

.. This is the log.............!!!


Comment below rating threshold, click here to show it.

gotosira

Member

02-27-2010

bump for help


Comment below rating threshold, click here to show it.

gotosira

Member

02-27-2010

this happens after the server got back up.... it never happened before.. i dun think reinstall would help this problem?? will it? T_T dun wanna download everything all over .. painful.. goshhh


Comment below rating threshold, click here to show it.

gotosira

Member

02-27-2010

seem to work properly now


Comment below rating threshold, click here to show it.

Basque

Senior Member

02-28-2010

Hello? Could I get any help? :S
Now it seems random, yesterday I could log, played a couple of games and now its back to the same o' same.


Comment below rating threshold, click here to show it.

Postal Twinkie

Wrenchman

02-28-2010

This error usually occurs when the game isn't being ran under administrative privileges, next time you launch the game instead of double clicking, right click it. When the menu comes up tell it to "Run as Administrator". See if that fixes the issue!


Comment below rating threshold, click here to show it.

Basque

Senior Member

02-28-2010

I figured as much, the first time it happened I did that and subsecuently there after.
It's somewhat on and off, its weird.
Now it's working, for instance.


Comment below rating threshold, click here to show it.

Basque

Senior Member

03-01-2010

So, I guess I'll just have to suck it up.
I shall play whenever the Launcher feels like working.


12