NVidia GeForce 9800M GT Graphic Problems

First Riot Post
Comment below rating threshold, click here to show it.

Rapps

Junior Member

08-13-2009

I'm currently running LoL with my Asus G50VT Laptop. I have been able to successfully run the game on the highest video settings at full speed (typically around 120fps out of combat, and 85 in) without graphical problems. After the latest patch (8/11/09 I believe) the ENTIRE ground floor of the game would go black as soon as I moved the camera; I also could not see spell effects. All the buildings and units were fine, but no trees, grass, or snow.

Strangely, turning down the Character Detail in the options to LOW (medium did not work) made the game worked properly. It's strange because the characters do not have issues, it's the ground that does, but the character detail fixes the problem.

I should also mention that my laptop is said to come with a 9800M GS, but Asus insists that I get 9800M GT drivers. Using the GS drivers I get serious issues and the NVidia control panel no longer works (all video control for full screen games, resolution, color, the works).


Comment below rating threshold, click here to show it.

Veigar

Producer

08-13-2009
1 of 1 Riot Posts

Thanks for reporting this Rapps. Here is an excerpt from our common problems troubleshooting thread (You've already found one solution but perhaps one of the other ones will work better for you):
http://beta.leagueoflegends.com/boar...ead.php?t=2372

4) When I enter a game, everything is black except for my hud and healthbars

Most likely cause 1: anti-aliasing is forced to on. Turning off anti-aliasing in the video card settings (I wish I could give exact instructions but I don't have a nvidia/ati console to look this up.)

Most likely cause 2: Toon line-ing is causing problems. Lowering to low character settings can fix this problem.

Most likely cause 3: The graphics card is not shader 2.0 or is very low memory like 64MBs (some shader 2.0 cards don't crash).


Comment below rating threshold, click here to show it.

Rapps

Junior Member

08-15-2009

Heh, I guess I didn't see the other post. Thanks for your response, I did have anti aliasing forced on (personal preference). After disabling it the game runs correctly on the highest graphic quality. Funny how a feature to enhance graphic quality completely destroys this game, haha.

A note for other NVidia users: To control anti aliasing you need to open the "NVidia Control Panel" by either right-clicking on your desktop and choosing the option there, or opening windows control panel and find the nvidia control panel in there.

On the left side, choose "Manage 3d Settings". Now you can change the setting here in the "Global Settings" but I would suggest you don't. Instead click on the other tab "Program Settings". If you choose the program settings tab you have one extra step: click "Add" and locate your League of Legends executable inside the installed folder (most likely C:\program files\league of legends\game\league of legends.exe). Make sure you choose the "league of legends.exe" inside your "Game" folder inside the install directory not the "lol.launcher.exe". Find "Antialiasing Mode" and choose either "off" or "Application Controlled" (application controlled is probably better).