Patcher stuck at 33%. Please help!

Comment below rating threshold, click here to show it.

DREWlikesDAwang

Junior Member

02-26-2013

I have tried literally everything on the forms. Nothing has solved it. Ran as admin, disabled my firewall, I have stable connection...etc. Literally everything than anyone says has failed. Please don't say submit a ticket because the support team has gotten no where. Its been a month since I could last get on the game. If you have solved this problem before please let me know. It started at the season 3 patch. All help is appreciated. Thanks.


Comment below rating threshold, click here to show it.

M3GaL0d0n

Senior Member

02-26-2013

Wrong forum... but since you're here, I'll make a guess that you've probably corrupted something... You can try to repair the installation by clicking the gear icon in the corner of the patcher and allow it to run and see if it actually works. Otherwise it is an error with your system and either your connection isn't as stable as you thought, or your system cannot receive data for whatever reason. Perhaps a device set up by your ISP to limit bandwidth usage. Try the Repair option and if it doesn't work reinstall the game entirely. It sounds painful at first, but it's the only thing that is going to get it working.


Comment below rating threshold, click here to show it.

Fluffy1

Senior Member

02-27-2013

33% is when the patch to the client is done and the patch to the game files begins, at this point it often stops tracking the download process, its a common bug but your patch is still continuing. its just a display issue. just wait it out


Comment below rating threshold, click here to show it.

M3GaL0d0n

Senior Member

02-27-2013

...I knew that...