Welcome to the Forum Archive!

Years of conversation fill a ton of digital pages, and we've kept all of it accessible to browse or copy over. Whether you're looking for reveal articles for older champions, or the first time that Rammus rolled into an "OK" thread, or anything in between, you can find it here. When you're finished, check out the boards to join in the latest League of Legends discussions.

GO TO BOARDS


Do I need OSX 10.5+?

1
Comment below rating threshold, click here to show it.

Outdoor Plumbing

Recruiter

11-09-2010

I'm trying to get my mac laptop set up for traveling and LoL-ing - I only have OSX 10.4 on my macbook - do I need 10.5 or higher? When I try the downloader it doesn't seem to do anything, just gives a fake maximize and then disappears.


Comment below rating threshold, click here to show it.

DBChill

Recruiter

11-09-2010

Yes you need at least Leopard (10.5+)


1