Need Help: maestro-server Problem after updating the recent patch

Comment below rating threshold, click here to show it.

AGQ2prA4skXk15DF

Junior Member

04-28-2011

Hey guys. Have a look on my problems. A little bit long.

After updating the recent patch, i got a disconnection problem.

Logs file

04/28/2010 16:32 [INFO] Solid LauncherLib [1.0.0.33] initializing...
04/28/2010 16:32 [INFO] Add App[League of Legends Launcher] Exe[C:\Riot Games\League of Legends\lol.launcher.exe] to Windows Firewall
04/28/2010 16:32 [INFO] Retrieving dynamic path[http://l3cdn.riotgames.com/LOL.Produ...SourceURL.xml]
04/28/2010 16:32 [INFO] Retrieved dynamic path [http://l3cdn.riotgames.com/LOL.Produ...SourceURL.xml][http://l3cdn.riotgames.com/]
04/28/2010 16:32 [INFO] Patcher_AddPackage([LOL.AirRuntime],[http://l3cdn.riotgames.com/],[C:\Riot Games\League of Legends\]) successful
04/28/2010 16:32 [INFO] Attempt to retrieve package [http://l3cdn.riotgames.com/LOL.AirRuntime.package]
04/28/2010 16:32 [INFO] Version retrieved [LOL.AirRuntime] 3/3 [AirRuntime.02_18_2010_01]/[AirRuntime.02_18_2010_01] type [PACKAGE_TYPE_INCREMENTAL]
04/28/2010 16:32 [INFO] [LOL.AirRuntime] State change [PATCHER_STATE_IDLE] to [PATCHER_STATE_ALLTASKSCOMPLETE]
04/28/2010 16:32 [INFO] Patcher_RemovePackage([LOL.AirRuntime]) successful
04/28/2010 16:32 [INFO] Patcher_AddPackage([LOL.Patcher],[http://l3cdn.riotgames.com/],[C:\Riot Games\League of Legends\]) successful
04/28/2010 16:32 [INFO] Attempt to retrieve package [http://l3cdn.riotgames.com/LOL.Patcher.package]
04/28/2010 16:32 [INFO] Version retrieved [LOL.Patcher] 17/17 [LOL.Patcher.04_12_2011]/[LOL.Patcher.04_12_2011] type [PACKAGE_TYPE_INCREMENTAL]
04/28/2010 16:32 [INFO] [LOL.Patcher] State change [PATCHER_STATE_IDLE] to [PATCHER_STATE_ALLTASKSCOMPLETE]
04/28/2010 16:32 [INFO] Patcher_RemovePackage([LOL.Patcher]) successful
04/28/2010 16:32 [INFO] Patcher_AddPackage([LOL.Air],[http://l3cdn.riotgames.com/],[C:\Riot Games\League of Legends\]) successful
04/28/2010 16:32 [INFO] Attempt to retrieve package [http://l3cdn.riotgames.com/LOL.Air.package]
04/28/2010 16:32 [INFO] Version retrieved [LOL.Air] 92/92 [LOL.Air.04_26_2011_02]/[LOL.Air.04_26_2011_02] type [PACKAGE_TYPE_PROGRESSIVE_VCDIFF]
04/28/2010 16:32 [INFO] [LOL.Air] State change [PATCHER_STATE_IDLE] to [PATCHER_STATE_ALLTASKSCOMPLETE]
04/28/2010 16:32 [INFO] Patcher_RemovePackage([LOL.Air]) successful
04/28/2010 16:32 [INFO] Patcher_AddPackage([LOL.Game],[http://l3cdn.riotgames.com/],[C:\Riot Games\League of Legends\]) successful
04/28/2010 16:32 [INFO] Attempt to retrieve package [http://l3cdn.riotgames.com/LOL.Game.package]
04/28/2010 16:32 [INFO] Version retrieved [LOL.Game] 70/70 [LOL.Game.04_26_2011]/[LOL.Game.04_26_2011] type [PACKAGE_TYPE_PROGRESSIVE_VCDIFF]
04/28/2010 16:32 [INFO] [LOL.Game] State change [PATCHER_STATE_IDLE] to [PATCHER_STATE_ALLTASKSCOMPLETE]
04/28/2010 16:32 [INFO] Patcher_RemovePackage([LOL.Game]) successful





When i starts the game, it creates a file on my destop, maestro-server.txt.
The content of the file is


INFO: maestro [server] initializing...
ERROR: Looking for air at LOLCLient.exe to fill in new proc info, but did not find it.
INFO: COMMAND LINE: Air\LOLClient.exe -runtime .\ -nodebug META-INF\AIR\application.xml .\ -- 8393
INFO: Using registered HWND: 459846 to launch the air client.
INFO: StartProcess [MAESTROPROCESSTYPE_AIR] successful
INFO: ReceiveMessage [MAESTROMESSAGETYPE_CLOSE]
INFO: No clients are currently connected.


After disconnection. The file content get changed

INFO: maestro [server] initializing...
ERROR: Looking for air at LOLCLient.exe to fill in new proc info, but did not find it.
INFO: COMMAND LINE: Air\LOLClient.exe -runtime .\ -nodebug META-INF\AIR\application.xml .\ -- 8393
INFO: Using registered HWND: 787476 to launch the air client.
INFO: StartProcess [MAESTROPROCESSTYPE_AIR] successful

I don;t know why this is happened. I can ping the riot sever with the two address.
1 - 216.52.241.254
2 - 66.151.54.190
I got 152ms in average.

I uninstall and install the game for several times. I need help.


Comment below rating threshold, click here to show it.

Phillycheese

Junior Member

04-29-2011

I'm also getting this problem, what's going on? I suspect that it may be a bug with the latest patch?


Comment below rating threshold, click here to show it.

Postal Twinkie

Wrenchman

04-29-2011

There is an issue with the Maestro connectivity, in this linked thread there are a few steps for troubleshooting Maestro errors.

http://www.leagueoflegends.com/board...ad.php?t=52018