Welcome to the Forum Archive!

Years of conversation fill a ton of digital pages, and we've kept all of it accessible to browse or copy over. Whether you're looking for reveal articles for older champions, or the first time that Rammus rolled into an "OK" thread, or anything in between, you can find it here. When you're finished, check out the boards to join in the latest League of Legends discussions.



Comment below rating threshold, click here to show it.


Junior Member


I've tried patiently now to try to download LoL on my mac for the past couple of days. My computer always seems to stop at this point and an error comes up saying an unknown error has occurred. I've tried plugging into an ethernet cord, deleting the lol_launcher file, and going into the rads folder and deleting files and relaunching the application but to no avail. Can someone who has experienced this help me out? I really want to play again and this is killing me!

Comment below rating threshold, click here to show it.




The issue is caused by the file VOBank_en_US.fsb getting corrupted during transfer. The patcher realizes the file has been corrupted, and throws up that error. This file is apparently one of the largest in LoL, and takes a while to transfer, raising the chances it'll get messed up in transit.

A few things people have tried that fixed the issue:
- Restart your cable modem and router.
- Try bypassing the router entirely, plug your mac directly into the cable modem. (fair warning, you may have to unplug the router from the modem, plug it into the mac, restart the modem. Then reverse the process when done.)
- Ensure you have no anti-virus or firewall software running.
- Try lugging your mac to someone else's internet connection (preferably with a different provider), sometimes your internet provider can fiddle with the data as it comes down the line.
- Force a re-patch using this method (https://support.leagueoflegends.com/entries/21804747-Patcher-Problems)
--- You need to adapt these instructions from windows to mac.
--- Under Force a Repatch, when it says to open the following directory: C:\Riot Games\League of Legends\RADS\projects\lol_air_client\releases\{highest version number}, you want to instead find your League of Legends.app file in Applications, right click and go Show Package Contents, then navigate to Contents/LOL/RADS/projects/lol_air_client/releases/{highest version number}. Follow the instructions from there.