Welcome to the Forum Archive!

Years of conversation fill a ton of digital pages, and we've kept all of it accessible to browse or copy over. Whether you're looking for reveal articles for older champions, or the first time that Rammus rolled into an "OK" thread, or anything in between, you can find it here. When you're finished, check out the boards to join in the latest League of Legends discussions.


Problem after the New Patch

Comment below rating threshold, click here to show it.


Senior Member


Today, after the patch, I started up a rank game. However, right when I was about to go into loading screen, it said I had an Msvcp80.dll error, saying that I had to redownload the application.

However, I went online to find a fix for it, downloaded it real fast, so it can get fixed.
Granted, it did get fixed, and I DID win my promotion series (yay) but later I also found out that downloading .dll files from a website is really risky, so I panicked and did a system restore to earlier today.

Now for some reason, League doesn't work for me - when I open it, I'll press the "Start" button, but no login screen appears.
I also tried reinstalling, but the problem still persists.


Comment below rating threshold, click here to show it.


Junior Member


happened to me before, if you google it you'll find something telling you to go into your folders, RADS and then projects, then delete 2-3 things in there, and then run it again, you'll have to repatch, but it worked for me

Comment below rating threshold, click here to show it.


Senior Wrenchman


System restore will generally break your install. The easiest thing to do in that case is usually just a reinstall, http://support.leagueoflegends.com/entries/234176-reinstalling-league-of-legends

If you want to try something a little more technical instead, as Fear mentioned, you can:

2a. Delete everything inside the your RADS downloads folder (Default Path is, C:\Riot Games\League of Legends\RADS\downloads) AND
2b. Delete everything inside your RADS solutions folder ( Default Path is, C:\Riot Games\League of Legends\RADS\solutions)
3a. Delete the lol_air_client folder in your RADS projects folder (Default Path is, C:\Riot Games\League of Legends\RADS\projects) AND
3b. Delete the lol_air_client_config_na and the lol_launcher folders inside the RADS projects folder.
3c. Restart your computer and repatch

You may also need to run the standard installer again, to restore the proper registry files

Downloading DLL files can be risky but if you're getting them from a reputable site, it's not as much of an issue.