Client problems? Help please?

Comment below rating threshold, click here to show it.

NATHANUS MAXIMUS

Senior Member

02-25-2013

So I used to normally have like 1 game crash every week...
Normal I presume....

Quite recently,
I have been having a crash almost every game.......

This really started to annoy me, so I decided to repair it.

Repair took about 4hours -.-
After it was repaired, every thing was fine.

I played 1 game perfectly. High FPS. No crashes or lag spikes.

Second game I played, the game went to hell from there.

Basically.

When Gragas drinks his barrel and he has all that stuff glowing by his face?
Its now a load of blue squares, almost like the game is not registering properly.

I repaired AGAIN
Twice in 1 day.

Then,
I played a game with Ashe on my team.
During log-in screen, her pic was just blue.
In game mini-map she was a blue square.
In the actual game, she was just a blue outline, no details, just blue outline.
All her abilities were just blue outlines.

Talon, whenever he used his poke ability, (not sure which button)
He basically throws 3 blue squares and anyone hit is covered in tiny blue squares.

Game crashes during log-in screen has rocketed sky-high.
Lag spikes in game are almost 7 per game...


Anyone have any ideas?
Please do not tell me I must re-download and re-install because fml.....
Lol


Any help appreciated


Comment below rating threshold, click here to show it.

JimsHardcore

Senior Member

02-25-2013

I had this once too.... The next game was fine. I just restarted my client and it was okay.
I updated my graphics drivers too.

Check for graphics driver updates for your graphics card, and try again.
I'm unsure as to what my issue was, but that fixed it for me.

ALL champs in my game had no image when kills were displayed.. I had to TAB everytime to see who died. Really annoying aha.

Haven't had to issue since updated graphics drivers though, so good luck.


Comment below rating threshold, click here to show it.

NATHANUS MAXIMUS

Senior Member

02-25-2013

Quote:
Originally Posted by JimsHardcore View Post
I had this once too.... The next game was fine. I just restarted my client and it was okay.
I updated my graphics drivers too.

Check for graphics driver updates for your graphics card, and try again.
I'm unsure as to what my issue was, but that fixed it for me.

ALL champs in my game had no image when kills were displayed.. I had to TAB everytime to see who died. Really annoying aha.

Haven't had to issue since updated graphics drivers though, so good luck.

Thanks man!
But I'm not exactly Tech Savvy lol...
How do I update graphics driver?

o.o