Welcome to the Forum Archive!

Years of conversation fill a ton of digital pages, and we've kept all of it accessible to browse or copy over. Whether you're looking for reveal articles for older champions, or the first time that Rammus rolled into an "OK" thread, or anything in between, you can find it here. When you're finished, check out the boards to join in the latest League of Legends discussions.

GO TO BOARDS


Won't load screen after champion select?

Comment below rating threshold, click here to show it.

Solaris Shadow

Recruiter

02-15-2013

@xxxWHITEGHOSTxxx are you bug-splatting even before you attempt to load into the game, also when you reinstalled did you make sure to remove any files that might have been left over, as well as run a registry cleaner such as ccleaner?
If not I would recommended reinstalling I know its a pain but left over files can cause a large amount of issues follow this guide:
https://support.leagueoflegends.com/entries/234176-Reinstalling-League-of-Legends

Just a note Make sure to test with a custom game rather then going into queue so you do not get a leaver mark on your account.


Comment below rating threshold, click here to show it.

xxxWHITEGHOSTxxx

Junior Member

02-15-2013

i get bugsplatted after champion select when it suppose to start loading in


Comment below rating threshold, click here to show it.

xxxWHITEGHOSTxxx

Junior Member

02-15-2013

im followed all the steps on that sight and im downloading the game again now


Comment below rating threshold, click here to show it.

Viking McNord

Member

02-15-2013

I repaired my client and it's still happening. I don't think it's computer issues, it was working fine yesterday and nothing happened since then.


Comment below rating threshold, click here to show it.

xxxWHITEGHOSTxxx

Junior Member

02-15-2013

i agree with him why would all the sudden all of us have this problem


Comment below rating threshold, click here to show it.

Sahgren

Junior Member

02-15-2013

This just happened to me twice in a row. Closing then reopening the client, then clicking on the "Reconnect" button didn't do anything.

Repair and a complete reinstall didn't seem to solve the issue either.


Comment below rating threshold, click here to show it.

xxxWHITEGHOSTxxx

Junior Member

02-15-2013

and even at 2k kbps it takes me a half hour to download this is wasting my life away i just wanna play league!


Comment below rating threshold, click here to show it.

Viking McNord

Member

02-15-2013

Currently reinstalling right now, but from what I've seen it won't do anything.


Comment below rating threshold, click here to show it.

MOCKINGJAYREBEL

Senior Member

02-15-2013

Same with me. Only happened when CPU asked for repair


Comment below rating threshold, click here to show it.

Viking McNord

Member

02-15-2013

Quote:
MOCKINGJAYREBEL:
Same with me. Only happened when CPU asked for repair


Come to think of it, I actually did repair my PC earlier today.