Welcome to the Forum Archive!

Years of conversation fill a ton of digital pages, and we've kept all of it accessible to browse or copy over. Whether you're looking for reveal articles for older champions, or the first time that Rammus rolled into an "OK" thread, or anything in between, you can find it here. When you're finished, check out the boards to join in the latest League of Legends discussions.

GO TO BOARDS


Riot help me now

1
Comment below rating threshold, click here to show it.

kodelleao

Member

01-30-2013

ok so ive been a active league of legends player and fan for over a year now and i love the game alot and i dont want to have to quit playing league because i cant get my game to work.... see the problem is i open NA or PBE and i hit play at this point on pother servers its working then i type in my log in info and i get a Server is Busy notice or Unable to connect to this server please vist this website so i looked up how to fix this problem and i did everything and tried everything that it said to and none of it worked i still get the messages and i cant play league.. i love the game and i dont want to have to stop playing it because i can get it to work

Edit: i have restarted my laptop
i have repaired LoL launcher
i have re installed LoL
i have turned my security off
i have synced my clock
i have waited for a day then tried again
i have updated my windows 3 times
i have gotten really pissed lol thought i throw this in because it happened
i have also re installed league for the purpose of the repair feature


Comment below rating threshold, click here to show it.

Fell14043

Senior Member

01-30-2013

Try actually listing everything you've tried, so people have a better chance of figuring out what you need to do. Maybe post your computer's Operating System.

Also, try running the repair feature. When you first open up League, right before you press play, look next to the 'minimize' and 'close' buttons for a little cog, that's the repair feature.

Try checking your firewall, make sure that League is on the exceptions list.
Are you running it as Administrator? If not, try that too.


1