Welcome to the Forum Archive!

Years of conversation fill a ton of digital pages, and we've kept all of it accessible to browse or copy over. Whether you're looking for reveal articles for older champions, or the first time that Rammus rolled into an "OK" thread, or anything in between, you can find it here. When you're finished, check out the boards to join in the latest League of Legends discussions.

GO TO BOARDS


PBE Server Status

1
Comment below rating threshold, click here to show it.

Pure Judgement

Junior Member

01-30-2013

So, It says the servers are online, but I get a server connection error when I try to log in. Am I the only one?


Comment below rating threshold, click here to show it.

Darkkor

Recruiter

01-30-2013

There is a maintenance go read the post.................


Comment below rating threshold, click here to show it.

Pearl da 4th

Junior Member

01-30-2013

The servers are currently down right now. they went offline an hour ago, don't fret they will be back online soon.


Comment below rating threshold, click here to show it.

Wards win games

Senior Member

01-30-2013

As stated: http://na.leagueoflegends.com/board/showthread.php?t=3061241

Maintenance updates will be posted to the above linked thread.


Comment below rating threshold, click here to show it.

mobafailure

Junior Member

01-30-2013

Quote:
XenGaming:
As stated: http://na.leagueoflegends.com/board/showthread.php?t=3061241

Maintenance updates will be posted to the above linked thread.



That link is coming up as invalid for me. Does it work for anyone?


Comment below rating threshold, click here to show it.

JustAaful

Senior Member

01-30-2013

Not I. Game working for others? I press "Play" and the loader just goes away and game doesn't load. On a mac btw.


Comment below rating threshold, click here to show it.

HivemindedOne

Junior Member

01-30-2013

Quote:
JustAaful:
Not I. Game working for others? I press "Play" and the loader just goes away and game doesn't load. On a mac btw.



Same thing happening to me as well. I click the icon to bring up the launcher, the launcher loads, heck it even patched just recently. Then I hit "Play" and the launcher disappears and nothing happens beyond that.

I think there's some sort of error within the new patch that is keeping the operating system from realizing the game is trying to launch.


Comment below rating threshold, click here to show it.

HorselesHorseman

Junior Member

01-30-2013

Same problem, also on a mac.


1