Has the "can't click in game" problem ever been fixed?

Comment below rating threshold, click here to show it.

AreYouIn

Junior Member

01-29-2013

So between google searches and reading these forums I've seen a lot of different threads about people who can't click on anything once the game starts. Some people seem to say it's intermittent and others say it happens all the time across a wide range of systems.

For me, when I try to play on my laptop I get this problem and have never been able to click once in game. I'm running XP, have tried fresh installs, updating directX, an external mouse, and a slew of other things suggested but nothing has ever worked. I submitted various support tickets but the most I ever got was the "disable anti-virus."

Unfortunately, on the laptop I can't disable the anti-virus - although I have no problems with anti-virus running on my desktop while playing.

One thing that I did notice was that the security agent on the laptop did log this:

The process 'C:\Riot Games\League of Legends\RADS\solutions\lol_game_client_sln\release s\0.0.0.205\deploy\League of Legends.exe' attempted to insert code ('C:\WINDOWS\system32\DINPUT8.dll') into another process. All processes were targeted. The operation was denied. [2701]

That's about the closest thing to a reason I've come up with but I don't know anything about this input.dll

So I guess 2 main questions:

1) Has Riot or anyone else ever identified what the problem is?
2) Has Riot or anyone else ever come up with a solution.

Follow up:

Why isn't this issue documented anywhere? (sorry if it has and I missed it)